Struggling With Animation / Section Plane


#1

Hi, i have a created a model of carpark (extension) that is made up of about 100 different groups and components that i need to animate (Section Plane) into the model to show a construction sequence. The car park already has 3 levels built and i am trying to show the animation for the extension of another level on top.

I am not sure what the best method is to use when section planing items, and as you can see in the video i’ve made below, it’s starting to go wrong very early :frowning:

I plan on spending the full weekend on learning how to do this correctly, so i would greatly appreciate any help that you could give to me on this, thank you.

MY APPROACH / PLAN
01 - i’ve gone and hidden all of the components / groups that makes up the car park level / extension.
02 - when i need to animate (bring in) a component / group:
02.1 - i unhide the component / group in the current scene
02.2 - add two section planes at either end of the component / group
02.3 - set the invisible plane as Active Cut
02.4 - hide the group and update the current scene
02.5 - unhide the group and set the visible plane as Active Cut and update scene

QUESTIONS
01 - should i use a different approach compared to my approach above… someone mentioned on youtube that you should add two section planes to all of your components first, and set the invisible plane on all components as the Active Cut before starting the scene animation… and then just make the visible plane the active cut in each new scene
02 - as seen in the video below… why are some of my components coming in on scenes that they shouldn’t be in (and coming in backwards)
03 - can you go back and add something into a group that you have already section planed in… if so, do i need to update all scenes when i’ve added something to a group that has already been section planed
04 - how do you turn off section panes from your animation / scenes so that they don’t show in your animation when it is playing… i’ve tried turning them off view menu and updating each scene… but they eventually come back again

Thanks in advance for your help.


#2

oo7

without seeing exactly how you developed your model scenes and sections, it is pretty hard to diagnose what is going wrong but be aware of a few things…

1- depending on how you are hiding and unhiding your elements may change the STYLE that your scenes are tied to. Updating your styles may be needed throughout the process.

2- If you are using active section planes on both ends of a set of building elements, there may not be a need for you to HIDE.

3- You can build your scenes with modified scene attributes… ie you dont have to capture the camera location. This can help preserve your sanity as you test through scene throughout this process. Simply go to the Scene details dialog and turn off Camera Location and any other attribute that you dont really care about at this time. The only one that you want to keep on is the Active Section Plane.

4- You may or may not know this but ACTIVE section planes can co-exist as long as each active section plane is located with in a separate group. This allows you to “hide” each animated group with a section at the same time. See the attached skp example. Open your STYLES dialog and see how I am also hiding sections planes using styles.hiding with sections.skp (18.7 KB)

5- I dont know if it would help but there is a plugin in the extension warehouse that helps folks build animated sections - http://extensions.sketchup.com/en/content/animate-sections Check it out and experiment to see if it will help with our workflow.