Strange artefacts occurring when using Follow Me with an elliptical pattern, but fine with a circular pattern

I’m making a dagger handle and I’m getting strange artefacts at the bottom of the handle when I try to use Follow Me with an elliptical pattern. I’ve tried doing the same thing using a circular pattern and everything worked, so I’m guessing it has to do with how I drew my ellipse. I drew a circle 19 mm in diameter and then used Scale and uniform scale about centre to stretch one side to 25 mm.

The only way I can give my handle an elliptical profile is to use Follow Me with a circular pattern, then use scale to squish it into the width and depth that I want. But I feel like I should be able to do all this with the Follow Me tool.

Ellipse will work if you put your profile touching the ellipse

Your profile seems to be broader than the shorter radius of the ellipse so the follow me result intersects itself.

I’m getting the same problem even if they’re touching.

I think this problem has something to do with the limitations of the Follow Me tool. I’ve been able to get it to work with regular polygons (eg hexagons)

and circles without a problem, and it also doesn’t matter what size those shapes are.


I think it has something to do with each cross section overlapping if traced around an ellipse. Scaling the entire piece to the right width and depth seems to be the only solution as of now.

1 Like

yep, exactly that, follow me can have some terrible results due to overlapping in curves, and in your case, scaling the end result might be better than scaling the path (circle into ellipse)