STL files going black (and unprintable)

stl
export
cadspan

#1

I just started using some extensions (Cadspan, SPGears_mjg) and when I export my drawing to an STL file, they come out totally black, and I cannot print them on the 3d printer. Also earlier made designs are turning black and become unable to print. It looks like the faces are reversed, but that is not the issue.
Who can help! I have to print my objects!!!
I work with SketchUp Pro 2015.
Thanks for any helpful answers!!


#2

Can you attach a simple SKP that displays this issue when it is exported as an STL…
Otherwise we have to guess.

PS: What STL exporter are you using ?


#3

With which program do you view them after the export?


#4

what happens if you import them into a new SU model?


#5

So many unknowns…
We await your help [so we can help you…]


#6

Thanks for the replies but I just solved it myself. I think the problem was I exported the file through an older plugin, and later installed CADspan. Export STL through CADspan again solved the problem!


#7

SketchUp has its own definitive STL exporter/importer available from the EWH…
Why are you not using that ??
https://extensions.sketchup.com/en/content/sketchup-stl


#8

That was the one I used. Downloaded CADspan to have some more opportunities gave the conflict.


#9

So have you tried the SketchUp EWH one ?
How does that fare ?