Speeding up SketchUp

Recently upgraded my laptop to a predator Helios 500. It has nvidia gtx 1070 card and core i7. With the ability to overclock (whatever that means). When I work in sketchup, modelling still lags. Not as much as it used too, but still bothersome. What are some ways I can optimize my computer and settings so sketchup can work faster for me? I want the ability to do it with textures and shadows on. Are there any computer settings I’m not utilizing?

read it from the user guide …

Then your speed will suffer. These are presentation settings. If you have the style toolbar open, it’s a one click button to toggle textures. Same for the shadow toolbar.

  • Lower the anti-aliasing
  • Use a fast style (no extensions, no endpoints, no profiles, no jitter, no depth cue)
  • Switch off fog.
  • Switch off layers your not working on.

This all implies that you’d have a presentation scene(s) with presentation style(s).
But would model in a special scene with a fast working style set for it.

The anti-aliasing is not a style setting so at some point when your model is done, you’d want to crank up the AA again.

3 Likes

No amount of fancy hardware can overcome poor modeling techniques.
See this compendium of performance modeling tips.

2 Likes