Some curves and circles on DWG not showing in Sketchup *SOLVED*

Hello, I’m running into an issue when importing a DWG from AutoCad in sketchup. This is my first time doing it.
I want to model a house using a DWG archive that contains some columns and curved walls. In Autocad I only have four layers and I see every component perfectly. But when I import it to Sketchup, almost all of the curves disappear. Some of them remain, and it has nothing to do with the tags because they are all on and the curved lines belong to different tags. How can I fix this? The columns are easy to redraw in sketchup but the arcs from the walls aren’t (at least for me because I’m a beginner). Please help!!
In this image you can see some crosses I made for guiding me into redrawing the circles. It’s de Citroham House from Le Corbusier
Sketchup|632x500

Here’s how the cad looks. You can see in the upper plan that one door remains when importing in sketchup but not all of them do.

Can you post the CAD file here? It’s hard to say for sure without seeing exactly how it was originally drawn. In the meantime, you can try exploding the curved groups/blocks and then re-importing them int SketchUp to see if that changes anything.

Eric’s idea is good. These objects could be of type not recognized by SketchUp and exploding or saving in an older format might help. I think the ACAD shapes are not very good, unless those jagged curves were part of the original design. They could be made out of a few arcs in SketchUp.

What does the dialog that appears in SketchUp when the import is complete show, especially in the "Ignored… " part? If “Proxy entities” are listed, the file has proprietary objects from something like AutoCad Architecture that should be “Exported to AutoCad” before you can import them into other applications. Another possibility is that the arched walls are drawn with splines - their behaviour when imported is somewhat patchy. Their jagginess in the screenshot might be a matter of the spline display settings in AutoCad being set low.

I just solved it ! Turns out the Cad’s insertion unit was milimeters, and this elements had a radius of 0.125. I changed it to meters and everything shows perfectly in sketchup. Thanks everyone for the help!

3 Likes