Solid objects - surface borders

Hi All,

I am trying to work out a volume using the cutnfill extension. The area has to be a SOLID to do that and every time that I check the geometry using the brilliant Solid Inspector2 extension it highlights all around the space as having surface border issues.
I have been through the forums and to be honest the definition of what a surface border issue is just doesn’t make sense to me. Can anybody explain it in a way that is meaningful and how do I put it right?

Why are the edges of the space picked up. I know it has no depth at this stage but surely the edge must be a special case???

Secondly how accurate is the volume calculation in Sketchup? I have a before and after model that I have eventually created as a solid by extending the base using the Vector joint push pull extension and then clearing down all the issues highlighted by Solid Inspector2. It has taken three days of work even though I have only used the sandbox tools to create the changes in the first place. I am amazed that sooooo many gaps are created even when the edges of the hidden geometry are selected! . The after has the area built up by almost 0.5m over an area of 3,400m with some levelling of the humps. However according to Sketchup Entity information there is only a 4 cubic metre difference in volume which doesn’t seem right.

Does anybody have experience of using the cutnfill extension before I fork out £20 on it???

As always your help and patience is greatly appreciated.

Please share the file.
Otherwise, we can only guess.

My guess, based upon your screenshot, is you’ve run afoul of SketchUp’s Layer system.


1 Like

Solid Inspector² looks to see if the group is a ‘solid’ - it’s not.
Then it reports why not…
In this case the surface has edges with only one face - these get reported.
A ‘solid’ must be a ‘container’ [group/instance] with just faces and edges, and every edge must support exactly two faces.
That’s why CutNfill says to add an ‘apron’ to the two before/after surfaces - it has a separate helper tool to do that.
Using another tool might not give matching aprons…
The two aprons must coincide to make a useful result.

Why didn’t you post your questions in the CutNfill forum at - I’d be more likely to see it there [I did write it!].
If you attach a SKP there - with the two surfaces [probably without aprons] - then someone will talk you through it - either an existing user or me !
Since the tool’s EVAL version only has 10 free goes, it’s best to start testing right !

PS: the licensed version is $20 from the SketchUcation Shop [not £20], and if you have a Premium membership it’s discounted to $16 - at today’s exchange rate that’s ~£13 !


Thank you for the response. I was using the push/pull vector option and I was hoping to use the solid tools to look at the differences between the volumes. A very very crude version of your CutNFill tool but then I thought somebody brighter than me must have done this already and then I found your extension.
I was right in my understanding that I needed to add an apron in some way for Solid Inspector so thank you for that. I have tried using CutNFill and I have posted on the feedback section as it still didn’t work albeit I am desperate to find out why as your extension looks like the answer to my prayers for many projects. I suspect that in correcting the internal and surface border issues in each of the models I have distorted the boundaries of the areas in some way. basic design1-4-volumes.skp (16.0 MB)

Thanks for your reply. What have I done that messes it up? I’m always eager to improve my knowledge. I have attached the file.basic design1-5-volumes.skp (11.7 MB) TIG has explained that I need to add an apron so that the edges are connected to two faces which seems to be the issue or my lack of understanding.

Hi. I tried to get a solid from one of your shapes. There are just too many problems with the geometry it seems.
First suggestion: Don’t drape a lot of edges on the surface you want to study cut and fill with. Leave that for later.
Second: Can you go back to the original input and NOT use SandBox?Use TopoShaper by Fredo or something else. If you use Toposhaper don’t do the apron–do the apron by the TIG tools recommended.
Third do not use any new layers. Do all your work for this study on Layer0. So: In the layer window, make sure Layer0 is the ACTIVE layer, and delete new layers that were created in the import and (on the prompt) place all geometry on the default layer (Layer0). It’s possible you don’t know how to use SketchUp layers and you don’t need them for this.
Fourth: follow the instructions for cut-n-fill. It requires you make the apron with the TIG tool as recommended.

Besides SolidSolver, CleanUp3 might be helpful for you.

Layers in SketchUp serve a different purpose than what you’re accustomed to in other applications.
Stop modeling and see these training videos …

Use a Style with ground and sky.
As it is, you’re trying to model with a nebulous white background.
It seems you don’t realize the model is some 96 meters below the ground plane.

Thanks Great advice. This is part of a much larger model but I take on board what you have said. I have created a rod for my back.

1 Like

Thanks Geo.