Soap skin buggy?


#1

It had worked the 1st time I’d looked at it, so I didn’t delve any further right then and there, but waited for a possibility of using it to arise.
Trying out the extension on curves I had, I bumped , a few times, into the “must select at least 3 edges” warning, which I had. So I reverted to a few other shapes I thought might meet the criteria, which they didn’t. The only fallback I had left was to repeat the example I had seen as a demo somewhere. The soap skin formed, but with a huge dent in it. Building another, similar frame, I got the same result. Up to my old tricks, I copied the corresponding corner, flipped it along and tried the substitution. Complete mismatch. The whole rigmarole is asymmetrical, although the substrate is completely regular (2 basic arcs and 2 parallel lines).
Should I go to Curviloft, or am I missing something?
What’s surprising is that this isn’t all over the forum.
soapskin buggy.skp (313.0 KB)


#2

You’d get better results if you’d set the number of divisions higher. I set it to 12 to match the number of sides in your arcs. Curviloft would work but you’d need to change your setup a little to get the same results.


#3

No wonder this isn’t headline news…
Three questions:
Are there any other options, apart from the subdivisions input?
Where are there guidelines, as far as acceptable basic frames for the extension to work with? The criteria are a bit fuzzy to me right now…
For example, does the starting geometry have to take into account it’s orientation with relation to the X,Y and Z planes?
Thanks for your patience and answers, even to lame questions.


#4

Follow-up question:
Looking at the repaired skin you sent me, I can’t help but notice that the vertices on the arcs and the end of the grid lines don’t coincide…
Wouldn’t it be better if they did, and how can that be achieved?


#5

Not on the initial skin creation but after it is created, you can select a few other parameters to adjust its shape.

I don’t know that there are any specific guidelines. I don’t have a great deal of need for this sort of surface. At least not generated as a soap skin bubble. When I use it, I usually draw basic arcs or other curves and don’t get to worked up about how many segments. The skin is created as a group so conceivably, you could discard the edges you drew. They are outside the group and not needed for the surface.

I would generally draw it so the skin is in the desired location and orientation so I don’t have to move it into place after creation. Often I am checking the shape of the surface against its surroundings so I want it in situ.

You’re right. They don’t coincide. As I already said, you could delete the original edges and leave the skin group behind. That would eliminate that problem. :smiley: You could edit the group and move vertices if you want. It kind of depends on what you are doing with shape once it is created. If you notice, the outer rows of quads on the sides are narrower than the rest. I expect there’s a good reason for it but you’d probably have to talk to the author to get it.

You should play with it and see what you get. Also see what it takes to create a similar shape with Curviloft and with TIG’s Extrude Tools set.


#6

Maybe I’m not looking at the right extension;
I’d like to combine the curves in the handset. I think I have all the XYZ profiles, but making them work together is another story…


#7

Curviloft would be a better choice.


#8

OK, I’ll look them up…
Should I worry about unsigned extensions?
Most of Fredo6’s stuff is.
Again, with the questions…
As ever, thanks.


#9

No. Don’t worry about that. Especially with Fredo’s extensions.


#10

This is endless…
The rbz is where it should be, and I’ve restarted SU.

No new tool shows up in the toolbar customizer, and as soon as I type the “l” in SU prefs, the search turns up blank:

I seem to remember Curvishear was already available to me as part of FredoTools, but it doesn’t show up in the Plugins folder.


#11

No. You didn’t install the extension. You dropped the RBZ file into the Plugins folder. That isn’t installing it and that’s not where the RBZ file is supposed to be.

Move the RBZ file out somewhere. Maybe your Desktop. Then use Install Extension from SketchUp’s Extension Manager (in the Window menu) to install it correctly into the plugins folder.


#12

Just goes to show you how proficient I am with computers…
I’m amazed I’ve gotten this far…
Up and running, thx.


#13

Following today’s events, one topic remains alive: Where’s a good place to keep the downloaded .rbz file after installation, since it’s not in the plugins folder? I’ve got a few from past installations that I’d like to hunt down and either discard or store adequately.


#14

Once you have installed the extensions, you can delete the RBZ files from your computer. If you ever need to reinstall, get them fresh from the source. Better yet, install the Sketchucation.com Extension Store and let it install the extensions for you. It along with the Extension Warehouse make it easy to keep things up to date.


#15

¨Better yet, install the Sketchucation.com Extension Store¨
It’s been also up’n running for a few weeks, one of the many things I’m having to sort out since recently entering the wonderful world of SU plug-ins. I’ve been modelling on and off for a few years now, but with Sketchup8’s basic tools.
Make17 and extensions is a whole other ball of wax…
Thanks again.