SKU Pro 2023.1 - Copy and Paste not working

Just installed the new update 23.1.315 on Windows 11. Copy and Paste between two istances of SketchUp Pro doesn’t work (?!?). Anybody is having the same issue? Any suggestion? Thanks.

1 Like


Yes, known bug, try this.


Thank you so much, it works! But I can believe the new update was released with a bug like this…

1 Like

I am still using 2022. My livelihood depends on Sketchup and Layout.

I am hesitant (frightened) to update with all the bugs and problems. The inability to copy and paste reliably is just crazy. I understand the fix/shortcut/workaround is there but really COPY and PASTE! That’s like forgetting to tie your shoes

I believe if my work was as untested and sloppy as the 2023 releases, I would be on the street looking for a new job.


I totally agree with you, unfortunately. I’m actually using both versions (2022 and 2023). I installed the new update hoping all the bugs of 2023 were finally fixed… they forgot to tie the shoes, you’re right.

1 Like

Same. Gonna stick with stable SUP 2022 at least until the user base is complaining about SUP 2024 and recommending everybody stick with stable SUP 2023! :grin:


Yup same issue… Was just about to create to a topic for this issue - great that the forum is here. The .1 update does seem a lot more stable however, and trays work properly now over the two monitors…

1 Like

the same here… copy/paste between two instances don’t work!!


Similar problem, tried rotating objects around a table and then dividing them for equal spacing, nothing copied the program crashed. Tried another way using the* and it worked. I’m with you though, how can a release have such a ‘known’ bug when it is such a basic operation

1 Like

Had the same issue, thanks for the workaround.

Same issue. The Trimble programmers are inept. Let them return Sketchup to Google.

1 Like

googles programmers were inept. Remember when they decided to let SU die and stopped working on it and maintaining it for like 5-6 years ? great time.

let them return Sketchup to Last. Last was the only time sketchup was good, it’s been going down the drain since.

edit: this is SARCASM. please react - or don’t - accordingly.

it works on mac os

You can’t mean this! They (same programmers as before) are working their αsses off and SketchUp is still going up (although with, as it seems, lots hickups recently). I’m quite confident that over time these issues will be be ironed out. It’s not like you snap your fingers and things are fixed.

oh, sorry, I forgot to add the SARCASM disclaimer at the end. :upside_down_face:

it’s an auto reaction when I see people asking SU to return to google. I invite them to return and stick to SU 8 since it was sô great.

(thanks for clarifying, you said … down the drain since)
About Google slightly killing SketchUp, yes!
I more or less sensed this when attending a Google “happening” in Mountainview in 2011.
All Google products got lost of attention, all but SketchUp. I even mentioned it at that time.

By the time I got back home Google had sold SketchUp. Thank g_d! SketchUp had been on a leash for several years.

1 Like

yeah, google has a history of buying or making products, they become more or less popular, but once they reach their initial objective, or don’t reach it if the goal was too high, they just take them on a trip behind the barn with a rifle and bury them discretely.

We’re lucky that SU got sold and not just scraped, and that it got sold to a company who decided to keep most of its model : a free version, a cheap pro version, the free warehouse, the open extension system.

I think over the years the main problem SU has had is the versioning. When you choose to do a yearly version, especially on a subscription, you HAVE to offer something new every year. We saw it this year, the QT implementation should have take a solid 1,5 year to reach us, but with a yearly deadline, they had no choice but to release in february with bugs. and they gave us mirror because, you know, here is your new tool.

I knew it was sarcasm before you edited your post!

I’m going to check into what @danbetteridge said.

1 Like

For me, I can rotate a copy and then type either /3 or 3/, and I get the expected other copies. Can you give your exact steps that lead to a crash?

Version 8 was, as a matter of fact, quite a good one. If I remember right, it didn’t bring many new things but improvements in stability and speed. But of course, things have improved even since then.

1 Like