SketchUp won't let me trace around edges of objects in 2D jpeg pictures

advice

#1

I’m a professional graphic artist and am attempting to get to grips with SketchUp Pro.
So far, everything has been easily intuitive, except what I’d expected to be really simple.
I’ve imported a jpeg photograph. It shows a cast brass plaque with raised 3D lettering. I want to draw (trace) around the lettering, so I can create a 3D image of the brass plaque within SketchUp Pro. Example click here.

PROBLEM: I can draw the lines and curves ok, but something in SketchUp is moving the lines and curves, as I draw them, ‘snapping’ their alignment to a grid or something. It’s not letting me put start and end points precisely where I want them, but is moving them to a slightly different position.

I assume I have to be looking square on at the jpeg (so it’s 2D not 3D) and that I need to turn off (de-select) whatever tool option is doing the auto alignment? Any advice gratefully received.


#2

Look in Window>Model Info>Units. Is Length Snapping enabled? If so, untick the box and see if you get better results.


#3

Hello Dave,
Yes, both LENGTH and ANGLE snapping checkboxes are ticked.

I’m suspecting it’s the Angle snapping is giving my greater problem.

Many thanks,
Rick


#4

Angle snapping affects the Rotate and Protractor tools but wouldn’t affect drawing lines except the Arc and Pie tools.

It might be that you are also seeing the Inferencing engine trying to determine where you want end points. With Length Snapping disabled, try tracing and see what you get. When I am tracing images, I often find it useful to use the Tape Measure tool to set intersecting guidelines at important points in the image. You might give that a shot.

Here’s an old thing I did a long time ago on tracing an image.


#5

Dave,
Nice craftsmanship. I once considered a career as a cabinet maker.

The line tool is now behaving itself as I’d expect. But, the arc tool isn’t. I put the origin of the arc where I want it, but when I try pointing to the required endpoint, it’s like when you’ve got two magnets repelling each other. As I move the cursor towards where I want the endpoint, the curved line looks good until I’m almost there, then it gets repelled and jumps past where I want it. Not sure if it is ‘snapping’, as in attracting or something ‘repelling’. What’s interesting is that the SketchUp line drawing tool is ‘aware’ of the edges of the letter image on the underlying jpeg. It is helping me align the straight lines to the underlying image, but in the arc tool it’s hindering me. Most curious. Any ideas?

Thanks again,
Rick


#6

Try using the 2-Point Arc tool instead.

Did you turn off Angle Snapping?


#7

Hi Dave,
I’ve just tried the two point arc, with and without snapping checked. Still getting odd behaviour.
Will try various settings over the weekend. It’s bound to be something obvious.

Have to go out now. Thanks for your assistance,
Rick


#8

You might also want to use Bezier Spline for drawing curves since it is unlikely the curves in the font are circular.


#9

As mentioned by @Dave, unexpected behaviour in this case is mostly caused by the inferencing system. You can zoom closer to reduce the effect.

Another point is the scale of the object, if it’s too small, you can get problems with arc creation too.


#10

As Coty mentoned, if your image is a tiny scale, just scalevit up, complete your design and recale to your final dimensions…


#11

Two other issues to look for. Firstly set the units to a greater level of precision (several decimal places). Secondly make sure that your geometry is close to the origin and/or there are no small pieces of geometry that are hidden and far from the origin. This is more likely to happen with imported CAD geometry than a JPEG but worth mentioning anyway.

Also as a general tip, the closer in you zoom, the easier it is to control the influence of unwanted inferencing. Hopefully at some stage Trimble will allow a way to temporarily switch off inferencing for this sort of purpose. Many people have suggested this over the years!


#12

Thanks Guys,
I’ve not had a chance to get back on Sketchup try out your suggestions, but I think you’re all probably correct. The image is likely to be very small. I’m also eager to try the other things you suggest.

Your assistance is much appreciated.

Rick @ Gatethorn