Sketchup won't install properly on new Mac Pro


#1

I have used sketchup for many years and never had any problems.
I have a copy on my mac book pro that works just fine. I am trying to install it on my new Mac Pro and it simply doesn’t work properly when I have installed it. I have uninstalled and reinstalled it numerous times to no effect.
It all looks fine until I try to draw, the pencil does not snap to any axis, if I click in space to begin a line, the prospective line does not show up as i move the mouse around the screen, it does not snap to any axis so it could be going anywhere, if i then click again to drop the line then the line does appear, but of course its placement is completely random. If I then try to draw a second line the pencil will not snap to the axis and so the second line will miss the first and again be random and anywhere in space. This makes it impossible to draw anything other than a random collection of unconnected lines!
Other tools such as Dimension simply do not work at all.
I have tried the following actions.

Reinstallation
Disabling hardware acceleration
Repaired disk permissions
Reset Sketchup’s preferences file

All to no avail.
All of which leaves me with a brand new £3,000 Mac Pro that is incapable of running the software that I bought it for!
Trimble technical support acknowledge there is a problem but cannot diagnose what it is, and suggested I asked around in the forum.

Any one come across anything like this before? Any suggestions greatly appreciated!
I am using Pro 2015 (15.3.329) and the Mac Pro has Dual AMD FirePro D300 Graphics cards with 2GB of GDDR5 VRAM each


#2

I don’t know the answer to the problem, but just to get more information:

Are you using a mouse?

Does it make any difference which of your monitors is the startup one?

Are both monitors Retina?


#3

Wow. Colin, what happened to Apple’s ADC labs - looks like it’s gone. I used to use them to test stuff like this. I suppose I could swing by our Apple Store a couple of blocks away and see if they have one of these in the store, to test. Have you tried turning off HW rendering?


#4

I’ll look into ADC labs, in case it’s still around in some form.

Note that Julian did say he had tried “Disabling hardware acceleration”.

All inference is working on my MacBook Pro, and Julian too has had years of SketchUp working on Mac. So, it’s something quite odd.


#5

Thanks Colin and Barry.
I have tried turning HW acceleration off.
My mac book pro has a retina screen and its fine. The mac pro with which I have the problem is using a 27" Thunderbolt display.
I use the same type of mouse with both machines (and indeed on my dell workstation with my Windows copy of Sketchup) that is a Rat 9 programable mouse, which has always previously been fine. Given the problem on the Mac pro I swapped out the mouse today, first to a mac mouse and then to a standard USB 3 button mouse, the problem remained with all the mice I have tried so far.
Its a real head scratcher…


#6

I’ll check with the Apple Store to see if they have one. Heard back from old Apple friends: about the time Google sold us, Apple closed ADC labs… too bad, that was a nice thing.


#7

Does the display have alternate inputs ?

If so, can you try with the HDMI or whatever other input the display has that you have an output on the MBP for ?


#8

Hi Dan
Its an issue with the mac pro (my mac book pro is fine) there is an hdmi out on the mac pro, but no hdmi port on the thunderbolt display.
The display is currently connected via the built-in Thunderbolt cable on the display. On the back of the display there are also three powered USB 2.0 ports, a FireWire 800 port, Gigabit Ethernet, and additional Thunderbolt port.
Do you think its worth getting a thunderbolt to hdmi adaptor and trying to connect to the mac pro’s hdmi using that?


#9

Or borrow one. It would be worth it for the SketchUp Team to know if the issue is only with the Thunderbolt output device.

Is there any reports of similar things happening (on Thunderbolt interfaced displays) with other software ?


#10

I can use my MBP Retina to a 27 inch Thunderbolt display, and things are working fine. I use Magic Trackpads.


#11

Shooting in the dark here - could it be related to having dual display adapters? That is, could SketchUp be getting confused about where in OpenGL land the cursor is?

Although I can’t rule anything out, thunderbolt seems to me unlikely as it is just a newer pathway for the same display output as Apple used previously.


#12

Thanks for the suggestions, still not sure what the problem was, and neither are apple, but they suggested I do a P Ram reset and that seems to have cured the issue for the time being.
I will keep you posted if it returns.
Thanks again


#13

If this ever happens again, before doing this, open terminal and do:

nvram -p

to print out your settings. It’s likely something with gpu-policy. Messing with this setting is extremely sketchy, so don’t. Just note what it is before the reset, and after, and ask Apple about it.