SketchUp Pro scaling issues saving as a dxf file to cnc cut?

dxf
cnc

#1

I bought sketchup pro because a friend turned me onto it seems to be more user friendly then auto cad or solid works. I’m using sketch up in its 2D form for drawing parts to be cut on a cnc plasma table. I use a program called sheet cam TNG which takes my dxf file and converts to a gcode it then goes to a program called Mach3 which runs my cnc plasma table.
When i say draw a object say a 5" circle I click file, export, 2D, options to make sure it is 1:1 which i can’t adjust size in that box and save as a dxf. I then open in sheet cam and the circle is always 2" bigger then what i draw it up as. How do I get around this problem?? Solidworks and auto cad the scale is dead on but those programs are way over my head to run. I really feel I have wasted my money on this License if I can’t get it to the correct scale.
Anyone else having this issue?

Thanks
Chris


#2

can you upload the .skp file ? 7th icon from left


#3

If the shapes you have drawn are 2D, the best method to export them to DWG or DXF is to use the 3D export option. You will get a better file, with true circles and arcs instead of a segmented representation.

If you need to use the 2D export feature, follow these steps:

  • turn your camera to Parallel projection.
  • select a standard view (probably TOP, in your case)
  • Now, export.

#4

What do you mean by using SketchUp in its 2D mode? It doesn’t have a 2D mode.

Before exporting, are you setting up a standard view of the circle with the camera set to Parallel Projection? Have you tried a 3D export? 3D DXF exports will yield circles as circles not as a collection of line segments.


#5

Everybody beat me to it…

Don’t worry you should be able to get it working.

Before you export, set the geometry at the origin, make sure it is flat on the blue plane, delete any faces,select top view ,set the camera to parallel projection, then export as 3d model/DXF. To get an accurate Dxf you must be in parallel projection.

(Top menu/Camera/Parallel Projection.)

Give it a try and see if that works…


#6

Sorry for my ignorance no 2D form I just meant I click 2D for export…Ok so I draw my object say a circle then click camera and click parallel projection I go to file click export as a 2D then click options as some say and make sure it’s 1:1 and then save as a dxf file. I have to save as a dxf or svg because that is the two formats that sheetcam reads although all I see is dxf so i save as a dxf when I import it to sheetcam the part is never the same size. Digging through this forum I found another guy having same problems over a year ago he said to keep it the same scale which I don’t know if it will work all the time which is to click camera, click parallel project, then click zoom extent, then click file, export, 2D, save as dxf and I was able to keep the scale the same for a circle for when imported to sheetcam but like a square i couldn’t keep the same scale when I imported it to sheetcam.

Little story here this is my situation, two friends built this cnc plasma cutter 3 years ago one friend died April 2016 he was the computer and electrical guy who wired this thing all up, talking with his old roommate today he would draw out in sketchup and finish off in Autocad because of the scaling issues in sketch up but I HATE auto cad it’s to hard for me to understand it. Sketchup is far more user friendly even though I still don’t know a lot about it. I have this awesome cnc plasma table at my finger tips yet this scaling problem is holding me back. My friend who build the table with my other friend he did all the machining and welding on this table and he and I are the same i am a pipe welder by trade trying to get smarter and learn the computer side of this but boy is it overwhelming LOL

Thanks
Chris


#7

Forgot to add I can not export as a 3D has to be 2D because sheetcam is picking up the edges of the plate in its 3D form maybe it is called the segments is technical term. Can I upload a picture here? I could show you what I mean.


#8

7th icon from left… or drag and drop


#9

Are you selecting a standard view that aligns with the geometry?

If what you’ve drawn is 2D and you’ve selected the appropriate standard view, you’ll still get a 2D file exported even though you’re using the 3D export option.


#10

Thats what I did just tonight, exported it in 3D some reason when i did it another time it wouldn’t work, so as far as I can see exporting in 3D it was the correct scale in sheetcam even though its drawn in 2D but I will use some 3d files my friend has drawn up that I know he has cnc cut on his machine that work and will run them in sheetcam to be sure the scaling is right. I’m glad it is coming together i want to learn more of sketchup I hate dealing with autocad


#11

AutoCad knows no difference between 2D and 3D. Everything in an AutoCad file is 3D - all points have x,y and z coordinates. Talking about 2D only means that in the objects concerned z=0 (or that it is the same for all points).


#12

Note: what @Anssi wrote is also true of SketchUp. Everything is always 3D, it might just all lie on a single 2D plane in 3D space.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.