Sketchup Pro Mac 2017 saving and file permissions oddity

error
mac
saveas
save_failed

#1

Hi all,

I hope I can adequately describe my situation here so please bear with me!

I’ve successfully installed the latest SU Pro 2017on my MacBook Pro and it runs great:

I switched to the Mac version with this upgrade because 2017 will not work on my Windows partition in Bootcamp/Parallels, despite the fact that 2016 worked beautifully. No matter, so long as I can read/write files from my Windows side all will be good.

I can create a new file and save it to my Windows drive without a problem. I can then make mods and continue to save it. If I close the document and then immediately reopen it, this is what I get when I try to save it:

if I click “save anyway”, I get this:

The crazy thing is that I can then do a “save as” operation and give the file a new name and it works fine and I can continue saving for that session. Once I close it, then reopen it, I get the save errors again.

This has to clearly be a Sketchup thing, yes? Windows and Parallels are working as they should, and I can use other Mac apps to work on files on this drive.

Any thoughts on what I can change in the Sketchup config to correct this? Or, how I can get SU installed on my Windows partition bypassing the OpenGL thing?

Many thanks in advance!
Smitty


#2

You can’t install SU 2017 on Parallels because Parallels supports only through OpenGL 2.1 and SU 2017 requires at least OpenGL 3.0. Until Parallels fixes this, there is no workaround other than to install an older version (and cope with saving as that version in SU 2017 so you can open the files) :unamused:. There have been a great many complaints about this (going back several years) on the Parallels forum, but they have been totally silent about any intent or plans to address it. Many posters there say they are switching to VMWare because it does support OpenGL 3.0.

Bootcamp is a different question, as it is not a Virtual Machine like Parallels. It is a full standalone WIndows running on your Mac hardware. The OpenGL support will be whatever the drivers installed by Windows provides. Of course, with Bootcamp you can’t run both macOS and Windows at the same time.


#3

Steve, I know that you’re on a Mac, but have you tried SU under BootCamp? I would be interested to hear what the experience is with this setup.


#4

No I haven’t. Aside from testing of extensions I write, I have no need to run Windows and I always got by using Parallels. Two things have converged that may force me to try it out (or switch to VMWare) at some point though: 1) SU 2017 will not run under Parallels, so I now have to assume that if my code is OK on Mac and on SU2016 on Windows it will also be OK on SU2017 and Windows, 2) my Windows is an old v7, which is at risk of going the way of XP at some point.


#5

I originally chose the Bootcamp route because I need to run Solidworks extensively and AutoCad/3dsMAX occasionally and I didn’t think Parallels would be up to the task. I assumed I would need to dual boot depending on what I was working on. I was wrong!

I discovered I can point Parallels to the Bootcamp partition and haven’t looked back since. Parallels essentially creates the “network” that allows the two OSs to communicate - there is no real time virtualization of creating a windows drive or compressing it. The only negative is that you are permanently assigning a portion of your hard drive to Windows and its apps. This has been the best setup I’ve ever worked on. Started years ago with XP, then WIN7 and now WIN10. Everything has worked a treat until I upgraded to SU2017 - 2016 worked beautifully on this setup. Windows boots faster the workstations in my department and Solidworks 2017 crashes far less often (if ever) than when I was on a PC.

My save issue is not a parallels thing in my mind though. If Sketchup Mac 2017 can CREATE and SAVE a new file throughout a working session on my Bootcamp drive through Parallels, why can it not reopen that same file in a new session and then save it? Sketchup must be misreading the file permissions, no? Of a file that it JUST created I might add. The Bootcamp drive is essentially a network resource and I have read elsewhere on this board that Sketchup Mac has had issues with SMB drives.

Is this something that Sketchup plans on addressing?

Thanks for all of the input!
smitty


#6

[quote=“slbaumgartner, post:4, topic:43295”]…Windows is an old v7, which is at risk of going the way of XP at some point.
[/quote]

extended support will officially be terminated by M$ at 14.01.2020.


#7

[quote=“smitty, post:1, topic:43295”]Or, how I can get SU installed on my Windows partition bypassing the OpenGL thing?
[/quote]

• SketchUp Help Center : Download older Versions

if still not running with the latest video driver avail disable: “Window > Preferences > OpenGL > Use Hardware Acceleration”


#8

Sketchup 2016 is installed and works beautifully. that is what I have my acceleration set to. SU 2017 WIN will not even open so I cannot make any settings adjustments.


#9

That setting no longer exists on SU 2017, so you couldn’t make it in any case. Use of hardware acceleration is now mandatory.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.