Sketchup Pro 2020- Unable to Start Free Trial

I also can not launch a trial version of SketchUp Pro 2020. I have downloaded and installed it but it keeps saying We were unable to start your trial. Please try again later. Does it ever works, the trial ?

Right now there is an entitlement server issue that is being worked on. Hopefully that is the issue. I’ll try to report back when it is fixed, but otherwise try again later.

Trying to start the trial now and am unable to because of the same issue. When will this work?

Any issues like that are short lived. What is the error you are seeing?

Same here with 2021 version - what gives…?

There is something odd about your account. It shows your first name as [, and last name as ].

Are you able to sign into this page?:

If you can, try the edit profile option, and see if your details look correct.

Hi Colin,

Yes, I can sign in successfully (through this link as well as the standalone SketchUp app), and the My Products page says I have no products…

Lemme know what you think,
Thanks

Hi Colin! I downloaded a free version for Sketchuo Pro 2021 and I can’t open the program. There’s an error stating the code cannot be executed because a MSVCP140.dll hasnt been found. The error is in Spanish. I’ve tried re installing the whole thing, rebooting the computer, downloading the latest .NET Framework, but no success. What can I do? image

Try these steps:

  1. Go into the Windows Add or remove programs control panel (the one whose title is “Apps & Features”).

  2. In the search text field, type C++. That will produce a list of the different versions of the libraries.

  3. Click on the latest version, currently that will have a name of “Microsoft Visual C++ 2015-2019 Redistributable”.

  4. Click on Modify, then Yes if asked by Windows for permission to run their installer.

  5. Choose the Repair option in their installer window.

  6. After the repair is finished, restart Windows as instructed.

Now try SketchUp.

Thanks for the quick answer Colin! I followed your instructions but I still get the same error message and I can’t open the app :frowning:

It would be worth trying the 30 day trial for SketchUp 2020, and see if it runs ok. If it does install and run ok, it may well repair whatever is going wrong with 2021 as well.

Here is the 2020 installer:

Windows SketchUp 2020 installer

Thanks Colin. I downloaded it and I get the same error but saying it cannot find VCRUNTIME140.dll image :disappointed_relieved:

Next thing to try:

  1. Go to Add/Remove Programs and uninstall the Microsoft Visual Studio C++ 2015 and above Redistributables (there may be a 32-bit and 64-bit version)

  2. Right click and re-run the SketchUp 2021 installer as an administrator. Once prompted choose Repair.

  3. Start SketchUp

BINGOO!!! Thank you so much! Very excited to start trying the program. :raised_hands:

I’m unable to start my trial. I’ve tried to make another account, reinstall SketchUp, and resetting my laptop. it is quite frustrating as I need to have it functioning for tomorrow.Screenshot 2021-03-09 155845

Did you have the trial running earlier?

Nope. I just made the account 2 hours or so ago.

Did you activate your Trimble ID?

Erro

Hello!
I’m trying to start my free 30 day trial (Sketchup 2021) but this message keeps popping up. Can someone please help? I’m afraid it’s urgent.
Thanks!

Yes i have. However, based on the fact that person above is having the same problem i dont think its something on my end.