Sketchup Pro 2020- Unable to Start Free Trial

Good day,

I hope I am posting in the right forums, I have recently installed Sketchup Pro 2020, however I keep getting a log saying that Sketchup is unable to start the free trial. I would appreciate your help, or if there is anything I can do to resolve this issue.

Many thanks,

1 Like

Can you login at (upper right)?
There, you can ‘Manage my subscriptions’ and see what ‘products’ you’re entitled to.
Maybe the trial-product is expired.

I too am having the same issue since last night. I’ve checked my account and can see that my free trial is still active but I cannot get the app to recognise the free trial. I can get onto the free web based programme but not the downloaded app. Can anyone help please?

Thank you.

There may be something wrong going on. I have escalated the issue to the right department.

Meanwhile, expect a message from me.

Thank you so much for your help. I look forward to hearing from you :slight_smile:

1 Like

Hello, I am also experience the same issue as described above.

Probably a dumb question. But have you tried clicking on the left hand item ‘Classic’ for licence type?

I think the problems being reported are just Trial, or at least Trial or Subscription. I had someone with that problem succeed with Classic.

Same problem on my end!

I’m as new user and can only share one image per post (??). Since the desktop pop up window have already been posted, I’ll let the web version.


I saw a blip on an alarm, so I pinged it within the last hour, and a bit slow, but all looked OK. I just tried it again, and it was faster: can you retry, and I’m wondering if it’s in all regions?

‘Ra’ is looking into it, there is a problem. I’m sending individuals a ‘classic’ workaround.

1 Like

Hi I’m having the same issue here

I’m facing the same problem too. Unable to start the trial period.

Same problem. Unable to start trial…

Same problem for me

Hi - same issue here, tried uninstalling, reinstalling - downloading from local reseller rather than directly. No dice. Thanks in advance for your help!

1 Like

i have the same problem with starting the trial

I’m having the same problem since yesterday… When will this issue be solved? Thanks!!

1 Like

I am having the same problem, with the same error message, when trying to start my trial.

Same issue here. “We were unable to start your trial. Please try again later.”