SketchUp Pro 2019 crashes when I open Thea Renderer Plugin


i am having a problem, the last two days, whenever i click to open the Thea render Plugin in order to render my model, Sketchup crushes!! it gives me the bugsplat reporter, i send the report but nothing happens

i have tried to clean my computer, to resave the file, to remake the file from scratch but nothing works!!

before that everything was working perfectly!!

anybody had the same problem??

What version exactly?
([menu]SketchUp->About SketchUp)
You need to have 2019.3 if you have the current version of Thea

thank you very much for your responce,
i have that programme


According to your screen shot you need to install the latest version. You’ve missed three updates so far.

Get the latest version at

and thea v1.5

and why was it working all this time?

Something has changed since you last used it. What? SketchUp 2019.0 is the first release from early last year so it’s not SketchUp on your computer that has changed? You would need to look at what has changed. Why not just install 2019.3 so at least you have the current version of SketchUp and go from there?

1 Like

ok thank you i will, but will that be ok with my subscription plan?

Version 1.5 Thea works till 19.1 SketchUp but is still a old version.
It might be that an OS update is in play.

After the release of 19.2, Thea version 2 had to update to 2.2
I do not think the old 1.5 will work

1 Like

Yes. It will since it’s still SketchUp 2019.

@Tomasz ?

1 Like

@DaveR thank you very much

1 Like

@MikeWayzovski thank you very much! so i download a newer version of sketchup and then see if i need to update thea and i contact them

You’re going to be all up to date. I think you should get a new hat that is up to date, too. :smiley:

1 Like
What’s your MacOS version? I am having similar problem with Curic Studio extension. The difference is that I have never used it with older versions of SU – I have purchased the latest version of that plugin & installed it under the latest Sketchup Pro (but older MacOS Sierra 10.12.6, MacBook Pro 2015).

Does anybody have an idea of what exactly might be the reason? Is it system based issue? Bad file paths? The developer does not react on my questions. You can find the crash log which I have uploaded to the thread where I was trying to find what was going wrong:

Thea 1.5 will not work in 2019, because SketchUp 2019 doesn’t offer deprecated C++ SDK.

Thea 2.2 will not work in 2019.0. Please update SketchUp to 2019.3.
2019.0 on has no necessary support for SketchUp C SDK that we use.

1 Like

@thesign i don’t know how i can help you, but i just updated everything as advised and now it works perfectly! maybe you should try the same! by the way i updated my MacBook Pro 2015 to the latest version

1 Like

thank you very much for your help!
everything works fine now!! :grinning: :blush: Thanx, I was hoping it might not have been the system related… Well, the time has come.