SKETCHUP ne reçois pas les infos de la carte graphique ni de la RAM

Je fais face a un gros souci avec Sketchup.
je viens de l’installer sur mon nouvel ordinateur (HP Spectre 360 Intel Core i7) et il crash sans arrêt.
J’ai tenté de réinitialiser, d’installer une version plus vieille, de regarder les paramètres de la carte graphique etc … au bout du compte j’ai tenté le Skecthup check et il apparait que le logiciel ne voit pas la RAM et ne reçois pas les infos de la carte graphique.
J’ai fait un test avec Can U Run It et ca fonctionne. J’ai également autocad et ça marche.
Je ne sais plus quoi faire, j’ai besoin de Sketchup pour bosser et je voulais le tester avant de l’acheter. Y a t il un souci entre Sketchup et Windows 10 ? Y a t il quelque chose à installer pour contrer ce bug ?
Merci de votre retour
Bonne journée

If it crashed, did you send the bug report? Usually, you would get some info about why it is crashing…

New computers with dedicated graphic cards often need to update the drivers, have you done that?

Pls do not double post…

Mike, this is the third post on the same subject from this member. I am not sure if he/she is failing to get a response because it is in french or for some other reason.

It is pretty obvious that there is no issue using SU with Windows 10 as so many others have them working together perfectly successfully. Not being on Windows myself, I cannot say why the RAM and graphics card details are not being registered. Could this have anything to do with how the OP installed SU. I have seen many comments relating to installing as administrator.

And just for the benefit of the OP, it is not a bug as it cannot be the software that is at fault if it works fine for most people.

Oui j’ai mis à jour les pilotes.
En fait les fichiers s’ouvrent et après une manip ou deux le logiciel se ferme
Ce que je ne comprends pas c’est qu’il ne detecte pas la RAM et les infos de la carte
Et comme je n’y connais rien … ce n’est pas simple :-(:confus:

Bonjour Simon,

Désolée pour le doublement de mes articles mais je pense que c’est sans doute le fait que ce soit en francais

Vous avez sans doute raison mais les gens ici se servent de Google Translate souvent. Pas d’excuse!

Est ce que vous avez bien installer SU comme Administrateur en fait? Je ne sais pas si c’est la ta probleme mais c’est quelquechose qu’on voit souvent ici.

Since you have a new computer, I presume it would have 8GB RAM or more installed and the Video card vcan take up to 4GB. That should suffice.
The error is a known issue that Windows does not report the right amount of RAM. Do not bother.

As @simoncbevans says, did you installed by rightclicking on the downloaded installer file and choose ‘Run as Administrator’ ?

If not certain, do it now (do not deinstall or anything) when prompted, choose ‘Repair’

This will repair your installation and might install some ‘Visual C++ libraries’ that your computer needs.

Do you get bugsplat? Do you send them? Have you received a notification with a number (and possible remedies)?

J’avais déjà opéré cette manipulation mais je viens de refaire “exécuter en tant qu’administrateur”
Je ne sais pas ce que sont les bugsplat mais je ne pense pas en avoir eu

Open SketchUp.
File > Preferences > OpenGL
What does it say ?

Ouvrez SketchUp.
Fichier > Préférences > OpenGL
Ça dit quoi ?

I’ve got the same trouble and need help because SU is my working software.

My Desktop is i9-13900 / 64Go RAM / RTX3070 Ti / Windows 11 pro 64bits
This desktop is new but SU 2022 worked well on it since recent time. I didn’t worked with for few days (weeks) and now opening a new document takes 2 minutes … not so exiting !!!
The checkup utility says there is no RAM and can’t dialog with GPU…

1/ I first disabled all installed plugins (except natives plugins) => no change
2/ I uninstall and reinstall sketchup => no change
3/ I updated some drivers => no change

I don’t know what to do else …

Does someone have a solution ?


I wouldn’t trust sketchup’s Checkup too much. on my computer it says I’ve 0 MB RAM too, instead of 48 GB, it works anyway. what did you change / install since the last time it worked fine ? was there a recent windows update ? any software installed recently that might interfere ? antivirus ? hardware change such as monitors ?

Hello Paul,

Thanks for your answer.
It is the problem, i don’t know what could interfere…
W11 updates => yes => I tried to restaure at an anterior point but it doesn’t work
Softwares or drivers => yes => libreoffice and chrome => I’ll try to …

have you tried installing a fresh 2023 version instead of 2022 to see if it works any better ?

Right-click on your desktop, select the Nvidia Control Panel. There, go to 3D application settings and check that SketchUp is set to use your Nvidia graphics card. If the setting is not immediately obvious, scroll down the list and set the “OpenGL rendering GPU” setting to point to your Nvidia card.

Thank you Anssi, but it does not work.

Yes Paul, 2023 is working… so I’ll have to go on it … even i prefered stay with 2022 like everyone in the studio.

Thanks for your help.

I’m guessing one of your plugins might prevent sketchup from starting quickly. are you sure you removed them all ? after 2022 uninstall, go to appdata > roaming > sketchup > sketchup 2022 > plugins and delete everything that is in it (you need hidden files to be shown in explorer options) and reinstall 2022 with admin rights. Try uninstalling vray / enscape or any integrated renderer as well if installed

Thanks Paul.
I uninstalled and deleted all sketchup 2022 (appdat/roaming & local, programfiles etc.)
I installed a new once,
and it is working again. So thanks a lot.

1 Like