SketchUp Make 2015 - [Older Plugin Migration Issues]


#1

Hello guys!
I uninstalled an old version of SketchUp this week, and then I downloaded SketchUp Make (the actual version that is in the website).
But SketchUp Make didn’t recognize my old PlugIns.
What can I do for activating them again?


#2

What OS are you running on?

Solution varies a bit depending, probably best to start with this… http://help.sketchup.com/en/article/38583


#3

Let’s assume Windows ?
What was the older SketchUp version ?
There are separate Plugins folders for each SketchUp installation.
Prior to v2014 the Plugins folder is in the SketchUp folder for that version [in C:/Program Files/..]
Since v2014 your Plugins folder is in:

C:\Users\YourUserName\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins

[or ../SketchUp 2013/..]

You could try copying some RB files [and their subfolders] over manually, BUT unless it’s a migration from v2014 to v2015 you may get painful issues, this is because many Plugins were rewritten to suit Ruby changes introduced in SketchUp v2014, and so older versions will sometimes cause load errors as SketchUp starts and not work, or work incorrectly.
It’s recommended that you note the Plugins’ names and download/install fresh up to date copies from the Extension-Warehouse, or the SketchUcation PluginStore…

You can have several versions of SketchUp installed at once, so uninstalling your older version was somewhat precipitous !


#4

SketchUp Plugin Compatibility
http://help.sketchup.com/en/article/3000050