Sketchup Keeps Making All My Components Unique

I’m encountering a weird problem with my component instances becoming unique without me telling them to. I can’t figure out what might be triggering it. I can correct the problem by selecting each set of instances in the outliner and using “replace selected” to make them all be the same component again, and then purging the unneeded duplicates. But after another hour or two of modeling, I’ll suddenly notice that I have a zillion duplicate unique components again. Any idea what could be going wrong?

That’s very odd. Are these Dynamic Components? Could you share an example file that exhibits this problem?

1 Like

do you have an extension that ‘organises’ components?

john

1 Like

They are not dynamic components and I don’t have any component related extensions installed. I’ve only been working on one file in the past few days when I’ve been having this problem, so I’m not sure if it’s specific to this file or if it’ll start happening in other projects too.

Here’s a link to the file: https://www.dropbox.com/s/fgj09ja063r5az7/Huntington%20Building.skp?dl=0

maybe @TIG or @tt_su has a script to un-make_unique

everything in that model is ‘unique’ and has bloated the file…

also, your Materials show an approx. size which may contribute to the issue…

sorry I can’t offer an easy fix…

john

1 Like

Right, when I go through and get rid of the unnecessary unique components manually, the file size was cut in half. But I’ve done that before and somehow it just keeps ending up with them all being unique.

Could you go into more detail about your comment about my materials? What does it mean for them to show an approximate size?

I’ll add the fixed-up file to the Dropbox if you want to take a look. I also went through and got rid of some unnecessary materials.

Here’s the cleaned up version: https://www.dropbox.com/s/fhcwutqx3nm2cig/Huntington%20Building%20(Cleaned-Up).skp?dl=0

when I opened the materials individually for editing, the ‘image’ ones show approximate

~

physical dimensions, as apposed to pixels or non approximate…

I always ensure mine have values that aren’t ambiguous, then I know they can’t cause any issues…

when you import them you can round up/down and then use ‘Position Texture’ to fill your requirements…

from a file ‘complexity’ standpoint, I believe that’s a better approach… [I may be wrong]

Once you have the ‘Uniqueness’ sorted there’s a plugin called ‘Texture Resizer’ that is worth looking at…

john

1 Like

Ok I see what you mean. I’ll have to look into that - thanks for the info!

SU will crop and combine textures. For example, the pawn shop window. R-click on each textured face > Make Unique Texture. Then select all the unique textures > r-click > Combine Textures.

I’ve made some window arrays. No new component definition was created.

Try a repair or reinstall SU?

1 Like

Oh cool, I knew about making unique textures but I never knew about combining them. Thanks for sharing your knowledge!

I often use ThomThoms old beta version of Component Comparison
After selecting everything I want to analyze, it finds duplicates and replaces duplicates. It doesnt always work but when it does, it is quite handy.

CD

2 Likes

Oh cool, I will give that a try if this problem keeps recurring.

What extensions do you have? There might be extensions doing stuff which you do not expect. SketchUp itself doesn’t make components unique - so there appear to be something else going on.

I’d start by disabling any extensions installed - then see which one causes this by enabling one by one.

(You are sure this model isn’t using groups instead of components?)

They are definitely components. The duplicates were really cluttering up my components window.

I have these extensions:

  • s4u-Make face
  • su2kt
  • Advanced Camera Tools
  • Dynamic Components
  • Sandbox Tools
  • Simplify Contours Tool
  • Trimble Connect
  • Photo Textures
  • Edge Tools^2
  • TT_Lib^2

I haven’t installed any new extensions in a long time and haven’t had this problem until recently. The only ones I used in the creation of this model were the s4u-Make face and the Edge Tools curve simplifier.

The problem happened 4 or 5 times before I posted but since then it hasn’t happened. I replaced all the duplicates with their parent components and they’ve stayed that way (unlike before). So I still don’t know what caused it or why it’s no longer happening anymore but hopefully it will stay working the way it should : )

Were the affected components Dynamic ones? There is a downside to using Dynamic components that whenever you manipulate one in a way that modifies its internal structure (like scaling a DC tiled floor so that tiles are added) in contrast to simple scaling and the like, a new component definition is added into the Component browser. If the DC has subcomponents with DC properties, the same goes for them. I find it annoying.

Anssi

Yeah I find that annoying about Dynamic Components too - but these were
just ordinary components.

Are your components themselves nested in different groups/components? Or do the components that are going unique have further components within them?

I have had issues in the past where the scaling of components have made them unique. I think it may have something to do with components and groups within a scaled component becoming impossibly skewed in the scale transformation(s) so as to give sketchup no option but to make them unique.

I seem to remember it happening more often with face me, or glued components.

Worth looking into.

They are mainly door and window components nested in groups that hold
various wings of the building. It was pretty basic stuff, no different from
other models I’ve made in the past, that I could tell. But I did have a lot
of projected textures from photos I was matching to to help me model. That
made the file size really big and maybe it was leading to the component
glitch somehow. After I finished the main modeling, I cleaned up the
materials to be mostly basic colors. That cut the size and since then I
haven’t had problems with the components duplicating themselves.

I didn’t do any scaling of components so I don’t think that extreme
stretching is the cause in this case. It’s good to know for the future
though; thanks for the input! :slight_smile: