Sketchup Freezes on opening


So when I open sketchup, this is what pops up and then it freezes. Does anyone know how to resolve this?? I have also tried uninstalling sketchup and reinstalled it to have the same result. This occured just today when I tried installing an extension from the Fredolibrary. I hoped that deleting the extension would help but even that didn’t work. What is interesting is the old file that I was working on still works and I can open sketchup through that.

The error message has to do with some extensions that aren’t loading properly. It’s hard to read in your image. It would be nice if you could make a proper screen shot showing it or better, copy the entire message text and paste it into a reply so we can see all of it.

From what I can see this looks like a permissions problem most likely due to incorrect installation. You could try repairing the installation by finding the downloaded installer, right clicking on it and choosing Run as administrator. When the options pop up, choose Repair.

1 Like

Hey Dave! Thanks soo much for ur reply. I traced the extension with run (it was hidden earlier and couldn’t find it) and found the folder finally. Upon deleting it everything went back to normal!

For the record, a program freezing means it stops responding to input, without crashing.

(Crashing meaning the program stops)

Thanks for the clarification. . . But the problem was exactly that! Upon opening sketchup, it would stop responding to input without crashing :sweat_smile:. Sorry for the miscommunication from my end.

SketchUp is not irresponsive. You can click OK and use it as normal.

The error box disappears before I can even click OK. So I end up with the frozen screen. Do u know the reason behind that?