SketchUp FBX/OBJ exports with individually selectable objects?

Hi all,

I’m a fairly new user to SketchUp using the program to try and build a few 3D models of an apartment building for use as art reference when drawing. I’m trying to export the file to FBX or OBJ, something I can use within my drawing program (Clip Studio Paint), and I’m hoping to make a few specific objects separately selectable so that I can move them separately from the rest of the model (i.e. the front door). However, when I try, a few different things happen:

-export to FBX: generates a 20MB+ file that makes my drawing program freeze and crash–whether because it’s too large for it to handle, or because it’s an ASCII FBX maybe? Blender can’t open them either because it’s ASCII.

-export to OBJ: generates a single object with nothing individually selectable, and also some of the textures/faces seem to be missing? (i.e. left grass face, entrance stairs)

-export to DAE, import to Blender and export to FBX/OBJ: requires me to explode everything in order for it to enter Blender at all, and then items get grouped strangely besides? The front door gets linked to like half of the 3rd floor and I have no idea why.

Thanks in advance, any advice is a huge help!
regency lodge model - exterior SIMPLIFIED.skp (1.4 MB)

I think I’ve found a solution–labor-intensive, but a solution nonetheless. Instead of having to explode everything to get a DAE that Blender can understand, I can just uncheck “preserve component hierarchies.” I still have to rebuild my hierarchies within Blender, but, it’s workable for now.

If anyone has a better, more automated solution, please let me know! If I can save time on this, I’d love to.

If I export your model as .DAE (with uncheck ‘Preserve Component Hierarchies’), in Blender it appears as a multitude of separate elements, missing faces and wrong geometry.

If I export your model as .glTF (glTF Export plugin in SketchUp Make 2017), In Blender it appears in grouped elements, but because in SketchUp you applied the material on groups and not on faces, the selection is difficult.

Instead, if I arrange the model correctly: grouping the elements, applying the material on the faces and not on the groups, orienting the faces correctly (with white outwards) and exporting your model also as .glTF, in Blender it appears in correctly grouped elements, and the selection by material it is very easy.

Ooooh, I see! I wasn’t aware .gITF was even an option, or that it mattered which face was oriented which way, or that there was a difference between applying materials to groups vs faces. I see I have a lot more to learn still about SketchUp haha

Thank you so much for taking the time to investigate this and explain all of it to me!

1 Like