SketchUp Crashing when dragging Model Material into favorites

All of a sudden I have not been able to drag a model material into a folder in “favorites”. I’ve tried multiple materials and multiple folders. One that I created today (which was the first to start the crash) and others that I’ve used many times before. In the new folder created today, I was able to drag 3 materials in there with no problem. When I tried a 4th, it crashed. I’ve since attempted to drag with multiple other materials than what initiated the first crash with no luck… Not sure what’s going on now. A little help would be appreciated

It now appears that it’s one of the textured materials that’s starting the crashing.

(1) When you do this, do you have the second Materials inspector pane open, and are you drag-n-dropping between one pane and another ?

(2) … or are you drag-n-dropping from the Windows Explorer ?

(3) Do you have your “personal” Materials path set to this “favorite collection” folder in
Window > Preferences > Files

(4) What is the path to the “favorite collection” folder that is showing the issue ?
It is recommended to be in a version independent folder down in your user “Documents” path ?
I do not recommend it be down in SketchUp’s “ProgramFiles” folders because of permissions issues ?

(5) Can you post a SKM archive (that causes crashing) so it can be examined ?
(They are actually ZIP archives with XML and image files wrapped inside.)

Oh, and did the BugSplat! window pop up ?

Did you send in the report with some information that can be used to locate it in the splat database ?

Dragging from Material pane to Material pane window

1.[quote=“DanRathbun, post:2, topic:25413”]
Do you have your “personal” Materials path set to this “favorite collection” folder inWindow > Preferences > Files
[/quote] Probably not. Will check. But don’t understand why it would work for some materials and not others


I’ll have to check these and report back[quote=“DanRathbun, post:2, topic:25413”]
(5) Can you post a SKM archive (that causes crashing) so it can be examined ?(They are actually ZIP archives with XML and image files wrapped inside.)

Same here.


How do I retrieve and export this archive file? These two materials seem to be the ones that trigger the problem,

Add the poblem materials to the “InModel” collection by either temporarily painting a face, or dragging them from a collection pane into the “InModel” pane.

Once a material is in the model, there are many more right-click context menu choices available.
Among them is “Save As…

Save the SKM archives somewhere like the Desktop where you can easily find them (or drag them from) to post into this thread.

Your other option is to just note the material names, and browse to the material collection folder where they reside, and attach them from there.

It actually Bug Splat Sketchup when I tried to save it to the desktop. This was a re-named material (or possible a new material created from an existing material) which was re-named to be more descriptive. I noticed the old version of the material in the Model Pane. I attempted to delete it thinking I had replaced all existing instances with the new material but it was apparently being used somewhere else. I also just tried to save the Old Material to my desktop as skm file.: Bug Splat again.

I tried it with a different textured image from that model and it worked fine. I also went back to the original component file that had that material which I brought into the model I was working on and it Bug Splat in that one too. The only thing I was able to do was to export the image and I’m uploading that here

I just downloaded that image, imported it into SketchUp and saved it into one of my collections. It worked fine for me. I expect whatever is causing the problem was stripped out or not included in the export.

What happens when you try the same thing?

By the way, that’ll make a nice texture forf a small panel or something.

Ok. I didn’t like the name of the JPG (with “%”) so I decided to create a new JPG from this material in an editor, safe it and replace the jpg for this material (within the sketchup edit window). This worked for this material. I was then able to drag it into a saved collection pane and no but splat.

Now I’m trying to do that with the other offending material. First I noticed that the name of the image (mahogany) didn’t reflect the color of the wood. I tried to do the same and ended up with a much darker color, though I hadn’t changed any color settings.

I then looked at the face entity and noticed a backside color which was much darker. Just in case, I corrected and eliminated the back face color.

I then went again to “open in external editor” and still the color doesn’t match?? Any Ideas?

This material I was now able to save as skm so I’m posting that as well.Acoustic spruce top.skm (594.2 KB)

Click on Reset Color next to the dimensions.

The skm has the yellow version.