SketchUp App Crashes


I am trying to view a model in AR on iphone and iPad through the SketchUp app. As soon as the process initialises the app crashes. Can you please let me know why that is? The file is only 65MB


AR is demanding, and 65 MB is big with regards to AR. The limit for AR in 3D Warehouse was 10 MB. We did try increasing that, I’m not sure what it’s at now, but would soon run into trouble with bigger models.

1 Like

Thanks Colin! How do I decrease the file size from 61 MB to 10 or under? I tried to remove all the unnecessary geometry and purge the whole model but it will not get any smaller!

Does your model include any images used as textures? What dimensions are the images, if there are any?

1 Like

The model consists of a site with multiple buildings on it and yes it does have textures in standard size. I found an app which can handle the model with no problem and I am surprised SketchUp can`t make it work. The app we are currently using is called Sight Space Pro and it allows you to view the model in all sorts including AR complete with geolocation (GPS accurate). The app can handle huge files. Maybe you should have a look at it to see how they do it. We would like to have this service available with the SketchUp official app since we are paying for a pro license. Hopefully you will find a fix ASAP so we can start using the official app. Many thanks!

Would you be able to let us look at your model?

@Barry works on the mobile team and should be able to tell why it crashes the app, if it also crashes his iPad.

yes of course Colin, is a dropbox link ok?

Yes, that would be ok. If you only want me and Barry to look at the file you could click my avatar and send a message to me with the link.

I sent Colin a photo - it loaded for me on a Gen 1 iPad Pro, 12.9" running iPadOS 16 beta… that’s a 6+ yr old iPad. I walked around the model and it seemed to behave OK.


Were you trying to walk around this model at 1:1? If I did that, your axis is below the model, and when I did that in my front yard, and then tried to move the model down so I could walk around the multiple buildings, it crashed. We’ll look at the crash report, but it is a large-area model with lots of buildings.


The model loads up fine when viewing it as you would in SketchUp (from above). The problem comes when switching the mode to AR. That`s when it crashes.

Table top view it’s fine for me. When I go 1:1 it’s huge, but loaded and only crashed. I’m still looking for the crash reports - I’ll give it a try again today.