Sketchup Animation does not call nextFrame on Windows

animation
ruby
windows10

#1

Hi,

I recently tried to speed up the simulation of our Sketchup 2017 Plugin by using start_ and commit_operation more. I also got a huge performance increase on my MacBook Pro, however my colleague, using Windows (he has an Intel HD 5500 graphics card), suddenly has a lot of trouble.
The simulation is implemented as an animation and created inside a tool like so

def activate
    @simulation = Simulation.new
    @simulation.setup
    Sketchup.active_model.active_view.animation = @simulation
end

Upon activation, the nextFrame(view) method of the Simulation class is called once and then once again when deactivate of the tool is called. In between nothing happens. I checked that nextFrame is not returning false.
(For testing reasons I tried to call nextFrame from the update method of the tool, which did advance the animation.)

Is there anything I could have done wrong with the operations? Does Windows behave differently than Mac?

Thanks
Tim


#2

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.