Sketchup 2022 + Vray 6 - Transparent background isn't transparent

Hi, for some reason I’m not able to render transparent backgrounds as transparent.

I’m working with Sketchup 2022 and Vray 6. I have my scene setup to render as .PNG and on the Environment settings I’ve checked off the background.

When I do the interactive rendering it looks ok but when I check the saved image, the background is saved as black.

I tried ‘Revert to default render settings’ and it still doesn’t work.

What is the extension of the file you saved and does it not have a transparent background?

Saved file is .png but it’s rendering the black background as shown on the frame buffer, instead of leaving that part transparent

See this article for more info. Basically you need to change the glass material in the Advanced material settings - switch ‘Affect Channels’ from color only to Color+Alpha or All Channels.

See test I just did. With default settings:

After changing material channel settings:

1 Like