Sketchup 2022 graphics issue - coplanar faces?

Ive had someone contact me with this today : drawing a flat object and then offsetting : this produces edges that aren’t always visible

I’ve spoken the user/trainer/reseller here who has run into this also (I5 Mac with Intel Iris, running 11.6 with SU2022).
It doesn’t happen for me on either my main Windows Workstation or my M1 Mac.

But just for anybody curious AND/or Reference, here is a file where it is happening for them and the images of what they are seeing.

IDH Edges Disappearing on Offset.skp (312.4 KB)

You can see that these interior edges aren’t rendering, however rotation causes them to reappear, similar to the OP’s issue.
image

@Elmtec-Adam When I open that file, the interior edges show up just fine for me, right off the bat.

Another Elmtec customer in the UK reported the same thing today, and they appear to be using Windows. I’ll send you an email with some questions about the user’s settings.

Hi Katya, I think it was me :slightly_smiling_face: who you spoke to on salesforce.

These work totally fine for me also, on both of my machines. There are other mysterious forces at play it appears!

I was tasked with looking into this further, and I found that if I disable my AMD GPU, and run SketchUp with the Intel GPU, the problem does occur.

I will create a bug report about the problem.

For anyone chancing across this post, here are some work arounds to the issue, while we work on fixing the problem.

The problem only happens if your geometry is completely flat, and you are in parallel projection, and you are on a standard view (Top for example), and you are using an integrated GPU, most likely Intel. It can happen on Mac or Windows. That may seem like a lot of things to have to line up, but it may be common when people are making floor plans, and like to see the plan from straight above. Any of these will solve the problem for now:

  1. Orbit by any amount. That could be a fraction of a degree, leaving the geometry looking the same as it does from exactly straight above.

  2. View in Perspective. The floorpan will look the same, if viewed from above.

  3. Add some other geometry that is closer to the camera than the flat parts. If the model has any amount of thickness to it, you can still be in parallel projection, top view, on an integrated GPU, and the problem won’t occur.

  4. Check to see if your computer has a discreet GPU that you can ask the system to use when running SketchUp.

Today’s update to 2022.0.1 has this issue fixed. You can get it here:

2 Likes

Thanks @colin That seems to have fixed it on my machine.

Having similar problem after updating to 2022. thought was a problem with graphics card but the driver is up to date.
The problem normally starts when modeling something small. but once it happens it goes to all the geometry.
Sometimes just drawing a line on a face is enough to see that line flickering.
Normally happens inside same group geometry.

I’m am running Sketchup 2022 Version 22.0.354 64-bit on Windows 10.
AMD Ryzen 9 3900X
NVIDIA GeForce RTX 2070

I am on version 22.0.354 and still having similar problems.

What you showed is a different issue. It should have been improved in recent versions, but there may be something different about your model. Can you add a simple example to your reply, that shows the problem?

An Skp file or a video of the problem?

SKP please. You should be able to attach small files to your reply. If it’s a large file, post the file online and reply with the link.

A small file solves the problem. that object I showed in the video is part of a big file. If I copy to an empty file it doesn’t show any problems. Unfortunately I cant share the big file.

So small object at a relatively large distance from the origin?

1 Like

@DaveR mentioned that could be multiple faces or distance to origin.
I cant share the file but to be fair that group is arround 40meters from the origin and on Red Axis and 20 on Green Axis and 3 meters on Blue.
Most of my models are with this kind of size. always work in millimeters and with big details in some areas.
This problem only came around since 2022 update. that’s why I was trying to figure it out.

testing on an empty file I can replicate the problem by moving from the origin to the coordinates I need.
So I guess I that’s the problem. Do you know any way of fixing it? I never experienced this before SU22 with similar files.

In the View menu is Component Edit. Try setting that to Hide Rest of Model. That may help when you are inside a group or component that is a long way from the origin.

I have tried with the rest of the model hidden or shown and it helps sometimes to hid it.
The weird part is that only flickers when I open the group or component. Once I go outside that group/component it is shown perfectly no matter how much zoom I do.
This doesn’t affect the modeling but it can be annoying sometimes.

I would be checking the relationship between the component origin and the model origin.
It sounds like one or the other has been set at a great distance from the geometry. Is there an imported dwg/dxf involved at all?