Select Tool lag issue on Windows 10

lag
pro
sketchup
selectiontool
windows10

#43

Did you try turning off Hardware Acceleration in Preferences,OpenGL?


#44

Dave…actually on this surface i cannot find anywhere where that is an
option. I’ve seen that on other PCs


#45

Did you look in the Window menu in SketchUp for Preferences>OpenGL?


#46

ah…i didn’t know there was an option there i was looking in the typical windows display area. Dave…that pretty much solved the issue. The selection box now shows up…sort of slow but dramatically better and usable. Thanks so much


#47

BTW prior to this, earler today, i’d tried to install the Intel drivers but they refuse to install after doing a h/w check – i think the surface must have surface specific drivers – and then i downloaded the latest drivers from MSFT…to no avail though.


#48

Turning off Hardware acceleration makes the CPU do the rendering so it’s not too strange that it’s a little slower. The fact that the selection window now shows up makes it clear that the problem has to do with the GPU and its drivers. Keep up on the driver updates and check periodically to see if you can get away with turning on Hardware Acceleration again.


#49

Actually, I don’t believe the problem is with any Microsoft Patches or Display Drivers causing this issue because one can easily select any surface/edge with the Selection tool by right-clicking on it … it’s only the left-click that has a problem and I can’t see how (other then via some very convoluted logic inside the SketchUp - and I’m a software developer since 1985 or so) that would have to go through Open-GL’s code while right-click doesn’t yet still works and properly selects what I need …
Trimble should look at the left-click code carefully, compare it to right-click handling and see how to get around this problem and be independent of any Open-GL, Graphics drivers instead of blaming others for this issue and do nothing (at least to the SketchUp Make 2017).

A, and I did try to disable fast feedback, and fiddle with pretty much everything I could think of on a brand new Win 10 Pro x64 with i7 8700K (Intel HD Graphics 630)… all to no avail, takes 5s each left-click…


#50

Why do you keep blaming Intel & their OpenGL implementation for your left-mouse-click handling code?
Try right-clicking on any object, it does get selected without any lag so the selection itself is working fast no matter what driver or Win 10 update is installed … it’s only the left-click that’s a problem so why don’t you review your own code (or send me the source of left/right mouse event handlers in your code and I’ll review them for you) to see what’s different in left-click that might be relying, unnecessarily (if it works with right-click then it should just as well with left-click) on OpenGL code and see how to do the same without that, or detect the problem (lag, and in such case disable some of your code on left-click that causes the lag).

What does your 2018 Pro patch do exactly and why can’t you patch Make 2017 the same way?


#51

I am not affected by this issue, but given that a few people were using Surface Pro, I wondered if the delay setting Microsoft have to help ignore taps is involved?

https://support.microsoft.com/en-us/help/4023466/surface-touchpad-use-and-settings

Also found this article that talked about the delay being increased with the Windows 10 Creator update:

https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/touchpad-delay-after-windows-10-creator-update/3824c902-9ac8-4e33-a7ff-7d2b8630287e


#52

I had the slow down issue with Skethup Pro 2017 on a Surface Book Pro and I was able to resolve it by changing the setting on the NVIDIA Control Panel. I changed the setting specifically for Sketchup to use “High-performance NVIDIA processor” from “Use global setting (High-performance NVIDIA processor)”.

I’m not sure why this was the issue since my global setting seems to be using the NVIDIA processor. Anyway, it fixed it and I hope that this will help someone else out there.


#53

I’ve ran the script first with your download and again from the command line but I still have the problem. I’m on a Surface Pro using SU 2018 Pro. Is there any further help for this serious problem. I reinstalled SU 2017 and it has the same issues. I then reinstalled 2016 and it was marginally better.


#54

What worked for me on my Surface Pro Tablet was enabling this workaround mode (from a Command Prompt):

"C:\Program Files\SketchUp\SketchUp 2018\jsonpatcheditor" Preferences WorkaroundDrawXorRectUseGLFlushNotFlushDraw b true

#55

#56

Hi just thought I’d share this by right clicking on the sketchup logo on the desktop and selecting “run as administrator” my lag problem disappeared.


#57

Jees, what did you do? I’ve be having issues with this since SU2016! worked instantly for me :slight_smile:


#58

hmmm…restarting fixed it this time. I had to restart 3 times though.


#59

hi, the workaround not working for me. any other ideas
thanks


#60

Gus, Are you running SketchUp Pro 2018? Did you install it in the default location?


#62

Are yall working on a resolution for make? I used this resolution for my trial version of pro and it worked but now i have make and still have the same lag issue.


#63

Find a version of the graphics drivers that work with your card and don’t create problem and then stick with it. If Microsoft pushes a new one that slows it down again, roll the drivers back.

I wouldn’t expect the SketchUp team to do anything with SketchUp 2017 Make at this stage. You’ll just need to do what everyone who is having problems does.

It’s too bad your computer doesn’t have an Nvidia graphics card because they seem to be rock solid.