Select Tool lag issue on Windows 10

lag
pro
sketchup
selectiontool
windows10

#23

Jeff, I think you misunderstood Ty. He was indicating that the script only works with SketchUp 2018.

If you’ve installed SketchUp correctly, the things to do are:

  1. Try updating the Intel graphics drivers.

If that doesn’t help…

  1. Roll back the driver to an earlier version when it did work.

  2. Get a graphics card that is reliable and up to the job. Intel Graphics HD GPUs are well-known to be lacking in proper OpenGL support. Of course upgrading to a good card (Nvidia) may not be possible without replacing the entire computer. Such is the case with most notebook computers.

  3. Go back to an older version of SketchUp, such as 2016, that allows you to turn off Hardware Acceleration and dump rendering duties back on the CPU.


#24

So I tried selecting and deselecting things in preferences, and in my
graphics card settings as well. I finally just re installed 2017 Sketchup
and chose the “repair files”. It worked, it was like an early early
Christmas present, so sweet. THEN I woke up this am,opened Sketchup, the
lag has returned! I have no idea what the problem is. I haven’t had any
updates in the past 3 days. Nothing has been altered on my computer. So
what do I have to do? Buy a new computer? What do I buy? What are the
requirements? I mean according to Sketchup diagnostic tool I meet all
requirements. It is so frustrating, and frankly keeping me from purchasing
the PRO version.


#25

I am on Windows 10 with an Nvidia and have never had to rollback updates. I had an issue some 6 months ago. I updated my Nvidia driver and the problem went away. However it has now returned and affects SU 2017 and SU 2018.

I have always use “Run as Administrator” when installing all Windows applications. I have a friend who has an AMD Radeon graphics card. He is running Windows 10. He is experiencing the exact same problem.

I can duplicate the problem with a very small script. The script is run from the Extension menu under GKWare Test. It simply creates 100 square components. This is always fast. Then I create another component manually and watch the blue circle of death spin for around 20 seconds or so. The component is finally created.

What is very interesting is after the initial long wait I can create another component manually without any noticeable slowdown.

I have looked for KB4013429 and KB4015438 but neither appear in the uninstall drivers list.

gkware_test_v1.0.1.rbz (2.0 KB)

Since I don’t do much manually creation of components this doesn’t affect my everday programming. However - I would still like to resolve it.

Does anyone have a complete list of bad windows driver updates?


#26

Ty_s,

what is the correct way to run the script fix once it is downloaded. I just bought SketchUp Pro 2018, downloaded the script, tried to run it and there is no change to the select tool lag in SketchUp Pro 2018.

Thanks,

Jeff


#27

I am happy to say that this problem is now fixed on SketchUp Pro 2018. I found how to roll back the most recent graphics card driver update and the select tool lag instantly went away.

In my opinion, Windows 10 is organized in a very illogical way, so just finding out how to determine which graphics card is actually on my laptop was a challenge. But, I did manage to revert to an older version of my graphics driver and this was an instant fix (I did also install the script provided at the top of this thread). These are the steps…


Right click your desktop and choose display settings (note orange arrow).


Windows will show display options - click Display adapter properties


Click the Properties button


Select the Drivers tab


Click Roll Back Driver (in this instance, my computer shows this option greyed out).

Rolling back the driver instantly fixed the problem.


#28

I am told windows will reinstall the latest driver at the next update and the problem can return.


#29

That seems to be true from reading through the reports in which the problem was sorted by graphics driver rollback and then the problem appears again a few weeks later.


#30

How does one know that this patch is not a virus. Sorry just asking… I really need this fix but i am worried to download a patch


#31

being provided by a “SketchUp Team Meber” should be qualification enough to trust the source.

Addtionally, you can just open the contained BAT file (text format) with every text editor (or word processor) and evaluate the content (1 line) by yourself.


#32

Issue showed up for me all of a sudden last night. Glad to have found this thread, otherwise not sure what I would have done. Thank you all!

I’m on a 2016 or 2017 Surface Book running SU Pro 2018


#33

i have a surface pro…pretty new…w/an i7 and integrated graphics. What i’m seeing is the selection box doesn’t show up at all. Is this what you were seeing? i’m not to sketchup so i have not paid for the pro version and i’m guessing this patch only works for the pro version of the product. Is that true?

thanks for any help


#34

yes that is true.


#35

Thanks…well i guess my only option is to try the web version of this tool. I cannot really afford 700 for something that i really don’t use professionally


#36

That’s a graphics driver issue that’s not a part of Selection tool lag issue, but still may be helped by a driver update (or a driver rollback). Selecting stuff is still possible whether or not you see the selection box you are dragging across the screen.

Try going to Intel for drivers to try out instead of relying on Windows Update.


#37

You might want do a fallback to the less demanding SU Make version 2016.


#38

ok…i can do that and see if it helps. I’d sure rather not go to the web version of the project quite yet.


#39

i didn’t even think that that was an option…are the older versions available?


#40

Did you click on the supplied link?


#41

doh…didn’t even notice that it was a link Dave. Let me try that


#42

ok…installed Make 2016 - 64bit…no real difference. Unsure if 32b might be better