Screen zoom ratio beyond limits!


I am new to Sketchup and now had the same problem twice now. I am using the free web based version on my Lenovo Yoga laptop.

Whilst using the track pad to navigate the screen, I have somehow enlarged the page resulting in all the tool bar functions now beyond the ratio size of the screen. The first time this happened, I could still access the tool bar just to save my work, now however the zoom is so great that all the toolbars have disappeared so I have no option to save. I don’t know if this is a Sketchup issue or a laptop issue so I may be asking to wrong forum, any help will be appreciated.

That sounds like the browser has zoomed the page. I’m on Mac so not expert on the variations in Windows browsers, but there should be a browser menu item to restore the page to its unzoomed size.

Try typing Ctrl-0, or go to the three dots menu and change the Zoom value back to 100%.

When using a trackpad, or any finger zoomable device, there are two basic focus options. If your cursor is in the work area the zoom focus is on your model, but if your cursor is on any toolbar or part of the browser border the zoom will act on them.

1 Like

Thank you for your responses, I have managed to get out of the problem but I’m still not sure how I got into it in the first place or the correct way out. I used the “shift + S” which brought up a help search, from this I could save a new file, then restart my laptop, all back to normal.

From your answers, I am inclined to think this maybe my laptop has caused the zoom and not Sketchup, but I may be wrong. Although I am using a web based version, the App provided doesn’t actually open in my browser so I do not have the usual tool bar found in my web browser

The examples you have shown all have the toolbars still visible on the screen, just at a different size according to the zoom ratio. When the screen zoomed whilst I was using Sketchup, no toolbars were visible. both the side toolbars and the top and bottom bars were missing. The only way I can explain it, If I was to use the “snipping tool” on windows, and selected a section of the Sketchup screen, then enlarged this selection to full screen, this is what I have. I know the the tool bars are still there from my first experience, but they are outside the perimeter of my screen. The zoom also only affects the Sketchup App, all other applications are as normal.

I haven’t ruled out the App causing the issue but I suspect this may be my laptop that has caused this. Although should I have the same issue again, I may be calling on your advise once more.

Many Thanks

Windows has a magnifier application that I use on my work computer. When the magnifier application is running in the background (which I have activated permanently for my convenience), pressing Control and Alt simultaneously, then using the mouse scroll wheel will zoom the entire screen (including multiple displays). This feature is handy to look at some detail in a magnified manner.

The macOS has a similar feature that can be enabled via the Accessibility settings, as I recall. I have it turned on on my home Mac. Pressing Control and using the scroll wheel zooms the screen on the Mac.

What “app” are you using, then? Can you show a screenshot of it?

I’m presuming the web app- when you do a local install it stops looking like a browser.

Here is the button to install web apps/PWAs in Edge (it is similar in Chrome)

This installs some files to a fixed location, so you don’t need to rely so much on your net connection and it will show up on the apps section of your browser.


It also means you can make a desktop shortcut, have a pinned taskbar icon etc, just as you would for any locally installed program.
This is one of the ways that SketchUp for i.Pad maybe could be provided : “add to your home screen” normally causes the same thing to happen on IOS

1 Like

Hi Thanks for your response, I have included a screenshot of what is happening, I am convinced that it is a command related to the touch pad, although I’m still in the dark as to how? I now relaunch the app from the laptop toolbar in a new window then close the one I’m having problems with, I’ve set the auto save to 3 mins so that I just need to wait a short while before closing. Would still like to know why this is happening and how to rectify the problem without closing the app.

Problem solved!!

The zoom problem occurs when I use the pinch zoom on my trackpad with the curser over the Sketchup toolbar, this causes the screen to enlarge beyond the parameters of the screen loosing the vital toolbars. fortunately the toolbar I pinch zoomed on is still there, just much larger. this enables me to reverse the problem and zoom in on the screen with my track pad, all back to normal. Like everything, it’s easy when you know how!

Again thanks for your suggestions.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.