Save monochrome light direction to scene

I’m trying to save multiple monochrome scenes

but I’m having difficulty when changing the North direction because it also changes other scenes as well.

I understand that shadow doesn’t behave that way since it makes the position of the shadows to fixed direction but how can I achieve this in monochrome mode?

Thanks in advance

What version of SketchUp are you really using?

Do you have Scene transitions enabled? Try disabling them and then make the scenes.

Are you using the Solar North plugin?

I’m using Sketchup 2021, when I turn off the transition it works,

but If the transition is turned off in rb code, it doesn’t seem to work

Please correct your profile, then. It shows you are using SketchUp Free (web).

Yes. That’s normal behavior.

Are you using some plugin to control transitions? If so, what?

I’m using my plugin to control transition

model.options["PageOptions"]["ShowTransition"] = false

and code runs through saved scenes and create monochrome scene for each one

and then it turns on the transition again

model.options["PageOptions"]["ShowTransition"] = true

It would have been helpful if you’d have mentioned that in the first post. Please move your thread to the Ruby API category.

Ah ok sorry about that I’ve moved it

You likely need to set each scene page to use it’s own ShadowInfo hash.

See: Sketchup::Page#use_shadow_info=

Once this is set, for each page set the NorthAngle and update the page.

Now when your code (or the end user) switches scenes they’ll see the NorthAngle change as well.