Sandbox - grid spacing not working right


#1

According to “Creating a flat rectangular TIN” (visible if you scroll down a bit in https://help.sketchup.com/en/article/3000132) , I’m supposed to be able to edit the default (10’) Sandbox grid spacing during the last of three steps required to create a grid. The first two steps - creating the 2D grid - work as expected, but entering a grid spacing into the box (third step) either does nothing, or lops off the grid to the size I’ve entered.

My actual intended use: I create an 800’ x 900’ grid (first two clicks), then edit the grid spacing to 25’. Result: The 800’ x 900’ grid comes up, with the default 10’ spacing. Entering 25’ in the last step to change grid-spacing changes the value-box entry, but leaves the grid exactly as it was before, with the default 10’ spacing.

My generic test: create a 100’ x 100’ grid (first two clicks), then edit the grid spacing to 20’. Result: a total dimension of 20’ x 100’, grid spacing still at 10’.

If this is a bug that I’m stuck with, I’m wondering whether there’s really any great magic to the grid once it’s created to my specs ANYWAY - or if I can just do the same thing “manually,” eg by drawing lines and then multi-copying them over my specified intervals along X- and Y-axes. My intent was to manually enter DTS values from an autocad file, shown on a 25’ grid, in order to do a volume calculation for the ‘terrain’ to be removed to reach the design contours. (Seems like I could have done it by now using that manual method, vs. all the futzing with the non-working grid…)


#2

1, Select ‘From Scratch’
2. Enter the desired grid size.
3. Pick starting point of grid
4. Drag to define ‘X’ direction’ and enter total width.
5. Drag to define the ‘Y’ direction and enter total height.


#3

Yes, the last step (5) should be the first, after activating the tool


#4

Thanks, that did work - though it’s not in that sequence in the tutorial for some reason. The VCB says to ‘enter grid spacing’ both before and after the X and Y axes are in place, which fuels confusion. Usually I just jump into tools like this and see how they work, but this time I started with the tutorial…that’ll teach me.


#5

?? sdmitch’s sequence seems right now that I’ve tried it that way. Maybe you mean that according to the instructions in the tutorial, it appears that (5) should be first?


#6

It is a little confusing. It’s just that the tool doesn’t end after the grid is created. You can start another grid with a different spacing immediately after completing the first one.


#7

I got busy with other stuff and just getting back now - to find that Smoove worked for about a minute while I was getting my bearings with it, before going on strike. I tried undoing a couple of things, never got any tool function back. I closed the file without saving, then re-opened - same deal. I can’t select anything after clicking on the Smoove tool. Even a new file with a new grid - can’t touch it with the Smoove tool. Any ideas?


#8

Are you trying the tool on vertices in the editing context of the grid? It does work on raw geometry, not on the outside of grouped geometry.


#9

I see what you mean now. I must have missed the part where I should have triple-clicked into the raw geometry to use the tool. Thanks.


#10

Update: I manually entered grid-spaced contour data, taken from a hard-copy that’s scanned in as my base layer, using the Smoove tool. It was tedious but I finished about 80% of that data-entry two weeks ago. I just found time to get back into it, but this time, when I open the raw geometry and select the Smoove tool, EVERY node in the grid lights up in yellow, even before I’ve moved the cursor off of the Smoove tool. I can’t find any way to unselect all nodes once they’re selected, without getting out of the raw-geometry selection entirely. Reducing the radius of the selection didn’t make a difference. Anyone got a clue on this?

Part B: I’d have gotten to 100% of my node-Smooving task on that same day two weeks ago, but for the fact that my reference hard-copy grid contains an irregular area wherein the grid is shifted somewhat off the first grid. Assuming part A of this is somehow fixable, is there some way for me to distort or “explode” the affected part of the first grid, so I can move these “not-on-grid” nodes to align them with the hard-copy locations for the shifted-grid area?


#11

You need to change the radius of the tool, then. Type a new, smaller radius after selecting the tool.

You should be able to open the group for editing and use the Move tool to move the nodes or crossing points on the grid.


#12

yeah, I went down to 1’…no diff. But it’s not even waiting for me to move the cursor over my workspace - as soon as I click on the tool, all vertices go yellow (takes about 2 seconds, that is)


#13

How large is the grid? That is, how large does SketchUp show it to be?


#14

I set it up to 25’, to match the hard-copy data that I’ve got.


#15

Here’s the basics of this file. IIRC I floated the grid slightly above the scan of the DTM sheet. That way, as I worked through the first part of the grid, setting the below-sea level elevations at each node, I would select a node, look up its elevation, manually enter that (negative) number, and each would sink below the scanned image. That made it pretty easy to track my progress, even when working in plan, as I needed to do to see points of reference in the not-so-great scanned image.

https://drive.google.com/file/d/1pmtSuexiAhKhuUQZ5r8LI0yzvZcWkCQL/view?usp=sharing


#16

Have you checked the size of the grid area using SketchUp’s Tape Measure?


#17

yes - it’s still 25’.


#18

I meant the size of the entire grid but now I’ve been looking at your model. It works fine on my end.


#19

I took advantage of ThomThom’s ‘vertex tools’ extension to select and erase the irregular, unneeded portions of the grid, outside of our work area. This gave me no problems at the time, but I do now wonder if there’s some tool setting that latched, or…I dunno.


#20

OK, what’s your hourly rate? I’ll sub the rest out to you… :wink: