Rotating rectangle precisely

I’ve attached a JPG which shows my problem. I’m rotating a rectangle (think 2x4 lumber), around a point on its upper edge, but I want to land a point on its lower edge with precision. If I could draw a true circle, I could do it by picking up the point on the lower edge from the circle, but circles in Sketchup are polygons so it doesn’t help. I find myself stuck on this issue a lot. Any ideas?

Freod6’s Fredoscale has a tool called Rotation (Free) that makes that dead easy to do. Other wise you can use the Arc tool to swing an arc centered on the center of rotation to identify where you need to grab the 2x4 with the native Rotate tool

Use SketchUp’s native ‘Arc’ tool (draw arcs from center and 2 points) or SketchUp’s native ‘Pie’ tool
to create/draw the exact arc over which the rotation should take place. Then use its start and end point to perform the rotation. “Dead easy” as @DaveR would probably say.

2 Likes

Like so:

1 Like

See this topic…

You should end the arc at the edge where you’ll grab the part being rotated, though.

1 Like

ArcAndRotate

dead easy:)

1 Like

Thanks you all! I’m not a total noob, but I’ve puzzled over this for too long (and searched a lot too, but it is hard to describe the search). In any case, I thought it should be brain dead easy and it is!!!

I can’t believe 5 answers in as many minutes and I had spent at least a few hours trying to figure it out!

1 Like

Well, "In the land of the blinds,…

I was trying out a different method i thought of without drawing an arc… but then I noticed that even with the arc method I end up a tiny bit off the true intersection, tolerances are set to 0" .000 on ˚. Guessing this is due to the arc difference of facets vs true circle?

skup

That was why @DaveR was correcting me

Yes, I had ended the arc at the lower side of the “2x4” where I intended to grab the piece, still got this discrepancy. I’ll try this again, maybe I goofed it.

Edit: Same result, with 100 sides in my arc I get closer but zoom reveals it’s not on the vertex.

Click through the Scenes in this tutorial model:
Brace Modeling Tutorial.skp (211.1 KB)

Try it with the segments set to 12, that should work,
which is basically the same as @Geo 's tutorial

Zooming in on the tutorial you sent reveals the exact same small discrepancies on the rotated end that I experienced. This does not seam to be present on the fulcrum end which was placed using inference and stays a vertex no matter how close I zoom. Just a curiosity.

I do not see those

Model Info :

Nor do I. I’ve tried a bunch of different sizes and shapes and all, at least visually when zoomed, seem to be exact.

I didn’t see the difference between Mikes first and second solution. So, I just moved the “correct” solution to the second version of MikeWayzovski’s answer. Is everyone in agreement that this is a solution that works regardless of settings?

1 Like

What software are you guys using to make the animated gifs?

Man maybe I’m losing my mind over here. This solution is totally functional I just got curious…

and so I keep trying this and seeing the same lack of convergence at the rotated end under very deep zoom. Now I agree the misalignment is effectively 0 and might be below Sketchup tolerances, but interestingly the fulcrum end which was placed using inference shows no separation under the same level of zoom.
I have tired this with arcs of 12 and 24 and 100 sides. Am I crazy? Can no one reproduce this phenomenon?