Rotated rectangle tool input

advice
bug

#1

When attempting to use the Rotated rectangle tool with the following sequence:-
1 click start point
2 drag along any axis (I’m starting with simple example)
3 enter length (VCB)
4 press ENTER (this works as expected and ‘protractor’ changes to conform)
5 drag to establish direction and approximate angle (at this stage VCB shows:- angle,~length and the screen dialogue shows angle, length, width)
6 press ENTER
however end results are either

  1. a rectangle of original length BUT with a width of the same value as I entered for the angle. (This is reported in the VCB with the original length and my input angle as the second value) I can resize using the VCB, but this does not seem to be what the tool is meant to do as it requires additional input.
    OR
  2. no rectangle with “Invalid input entered”
    (I have tried the input in both 45,200 and 45.0,200 with no different result)
    I have watched the video and downloaded the PDF, but cannot establish a method from either of these.
    The topic posted on Jun 16 does not really relate to my problem.
    I am using Sketchup make 2017 and never tried the Rotated rectangle in 2016.
    I’d really appreciate some comments, I don’t know how showing any examples would help the explanation, as obviously I’m missing some key point.

Rotated Rectangle Tool
#2

Try following the prompts beside the Measurement box (VCB) more closely.

If you click then DRAG first (as you say you did - i.e., hold the mouse button down as you move it), you get Measurement prompt Angle, Length.

If you click, then just MOVE the mouse (with no button pressed) you are prompted just for Length.
Type the length and press Enter.

THEN you are prompted Angle, Width.

Does that help?

PS. As far as I know, the method hasn’t changed since v2016. There has always been a variety of ways to use the tool- different possible sequences of operations like click, drag, move - and I have myself found it not a little confusing to remember the possibilities.


#3

Thank you John,
However if I simply move the mouse (no button) then enter the length, the measurment prompt is for Angle,Length, but it is “greyed out”, or stays white and will not allow any input. Yet if, at that stage I move the mouse, I can input data, but that is when I receive the “Invalid input”.

Thank you again, I shall keep trying.
Hal


#4

At least in SU 2017, I don’t get that. When I first click, then move mouse (no button pressed) I get the prompt Length

Let me try again in 2016. Same here too.

BTW, which version are you using? Your profile doesn’t say either Make or Pro, or which version.

I simply can’t get it to do what you are describing. It does for me just what I said in my first response to you.

It’s possible that @DaveR might be able to help you using a remote connection so he can see and/or demonstrate how to use the tool. Or if you have or could download the free TeamViewer program, I could myself (but not tonight - bedtime here now in uk).

PS. AHA!
I have at last reproduced what you describe. But only after repeated attempts. However, once it has started, I can do it again - every time, even after a SU restart.

That is indeed weird. And may qualify as a bug - certainly very odd.

PPS. Try restarting your computer - that might fix it.


Rotated Rectangle Tool
#5

Tried to do a screen capture:

Didn’t work at all first time, and missed the start second time.

Third try:


#6

Still misbehaving after computer restart.

Like you, puzzled and at the moment, baffled. Not getting entirely sensible results using the click/drag method either.


#7

I can duplicate that issue on my PC. It’s quite strange. I would say it’s broken. I checked SU2016 and it works as expected.


Rotated Rectangle Tool
#8

Glad to have a third person confirm the problem.


#9

Thank you everyone, I thought I mentioned I’m using Sketchup Make the free version, and I tried the traditional cold reboot, with no change in behaviour.
As before, after I enter the first length, VCB asks for angle,length, but will not allow access until the mouse is moved, after which I can enter data, but the invalid entry appears.

Thank you all again.

Hall.


#10

@DaveR, how or to whom can we report this as an apparent bug?


#11

I’ll take care of that, @john_mcclenahan

eta: Looks like it’s been done.


#12

Thanks. Is there a bug report already?


#13

Yes. I added to it, too.


#14

Thank you all again, my next question was to have been concerning a “bug report”. I must say how gratifying it is to a new user to have your concerns and queries dealt with so quickly and in such friendly manner. It appears Sketchup has more going for it that just the programme.
Hal.


#15

[DaveR] DaveR http://forums.sketchup.com/users/daver SketchUp Sage
November 27

I’ll take care of that, @john_mcclenahan
http://forums.sketchup.com/users/john_mcclenahan

eta: Looks like it’s been done.


Visit Topic
http://forums.sketchup.com/t/rotated-rectangle-tool-input/34718/11
or reply to this email to respond.


    In Reply To

[john_mcclenahan] john_mcclenahan
http://forums.sketchup.com/users/john_mcclenahan
November 27

@DaveR http://forums.sketchup.com/users/daver, how or to whom can we
report this as an apparent bug?


Visit Topic
http://forums.sketchup.com/t/rotated-rectangle-tool-input/34718/11
or reply to this email to respond.

To unsubscribe from these emails, click here
http://forums.sketchup.com/email/unsubscribe/49a143e74645b5f6f6dc81d56582653a07545ed816148f7a41cfe07be59e4baa.

I should have asked before, but how to I keep up to date with the “bug
fix” please?

Hal


#16

I think at this point just keep your eyes open for a maintenance release. Someone from the team may chime in here during the week, too.


#17

Hi Guys…having the same problem having just this day downloaded SU 2017 from the Maintenance Release Page, so assume is up to date and the problem is still there? What now please?


#18

Rotated rectangle tool:
I’ve just downloaded the latest update to SketchupMake 2017 and the Rotated rectangle is working.
Thanks to everyone for your help, it is conforting to realise "You are not alone"
Hal.


#19

Thanks for reporting back. I must try it again myself. Haven’t used the tool for some time myself.