Revit to Sketchup 3D with matching coordinates / origin

#1

Trying to Export elements from an existing Revit model (dwg or dxf) and Import into an existing Sketchup file with matching coordinates, so there is no need to re-align the elements and they are places in the “correct” location.

I understand there are both export and import options. Tried all combinations, imported elements still not aligning in Sketchup model.

Revit to dwg/dxf Export options:
Coordinate system basis:
[ ] Project Internal
[ ] Shared

Sketch up Import options:
Position:
[ ] Preserve drawing origin

#2

You could also try using an IFC file instead of DWG.

The “preserve drawing origin” option should also work. Did you perhaps export one file using the Project Internal coordinates and the other with Shared? Most probably the origin of your SketchUp model doesn’t match the Revit origin.
Without “Preserve drawing origin” checked, the imported objects are placed at the SketchUp model origin based on their extents so two exports with a different set of objects won’t match.

#3

Anssi,

The IFC file did not work. I will continue troubleshooting DWG or DXF but the coordinates between Revit and Sketchup still do not match. Not sure how to achieve this.