Revit Importer extension continuously asks me to restart; doesn't show .rvt as an option in file > import

Hi SketchUp Community,

We have just upgraded my work pc to the SketchUp 2024 Studio license (upgraded from Sk 2024 pro) specifically to use the Revit Importer feature. I have enabled the studio license, signed out of SketchUp, restarted pc, signed back into SketchUp, installed the Revit importer extension from extension warehouse, restarted the sketchup, signed out of sketchup, restarted my pc, signed back in…

  • Studio license definitely installed
  • Revit Importer Extension definitely installed.
  • Definitely restarted/resigned in etc several times.
  • File import menu does not include .rvt as an option - so I can’t perform the import:

Every time I open sketchup I get the same message asking me to restart sketchup:
image

Any ideas? Really need to import this Revit model as cleanly as possible, ideally preserving textures & converting families-to-components. The whole point of upgrading my license from Pro to Studio was to use this Revit Importer: https://help.sketchup.com/en/revit-interoperability/revit-to-sketchup

Thanks All,
DS

Studio License definitely installed:

Revit Importer Extension showing as installed in the extension warehouse

However, the extension does not appear to be functional; there is no evidence of it working. There is no .rvt option in file > import.

There’s no ability to import a Revit model using the file import menu:

My suggestion you can try:

Make sure NO SketchUp (and Layout/Style Builder ) is running. (Perhaps restart your computer to be sure)
Go and download a fresh copy of the installer file from official site: Download All | SketchUp | SketchUp
When it downloaded right click on the installer file and chose Run as administrator.
When prompted chose Repair.

Let see if you run SketchUp how it goes. If still not okay, you can try this:

Go and download Revit Importer .rbz via web browser from here. Revit Importer | SketchUp Extension Warehouse

Run SketchUp and go to Extension Manager and install the rbz of Revit importer by choosing Install Extension at the bottom.
Restart SketchUp.

Hi All,

Just noting that we found a solution, in case anyone else is searching for one.

I probably should have clarified - SketchUp was still technically operational at the time of my post (same operability as pro, except with an annoying notification every restart) - it just was not unlocking the specific feature (Studio’s revit importer) we were targeting after the license upgrade and extension install.

Fortunately, we have now resolved the issue by completely uninstalling SketchUp on the subject PC and reinstalling Studio completely fresh. That did the trick. Note: completely uninstalling previous copies is very risky if you don’t have a redundancy (which we did). Even though it worked in my instance, it’s still risky.

In case anyone is wondering - I absolutely love the Revit Importer, having tried it on 4 imports of large complex Revit documentation models of major projects at a construction stage. It’s so much better than any of the other workflows we have tried (not going to name names, but we have tried several). It’s crisp clean geometry, brings in materials and layers, and no errors in sight. It’s honestly beautiful. No, I do not work or have any affiliation with google or trimble lol. Am genuinely impressed (aside from the buggy upgrade process).

I haven’t tried any of the other Studio features - we only really wanted it for Revit 3D model imports.

Thanks All for your comments - cheers.

DS

1 Like

Thanx for sharing’ very interesting for the mechanical and electrical side of things’ as get arch’ job’s that use the Revit