Reduce vertices in Sketchup terrain mesh

would anyone know how to reduce the vertices in an imported stl terrain GIS mesh to Sketchup. The stl was exported from Blender, and some changes had to be made so the stl was imported to Sketchup and modified. I know you can smooth edges but as you may already know this does not help when you try to export again as an stl as the smoothing edges seems to be a temporary viewing feature on Sketchup. Here is an image below:

I would really appreciate the help. I don’t know how to export a permanently smooth component to an stl file without having so many vertices. Thanks.

But from what can be seen in the picture, you will actually need to create a denser surface in order to smooth it out.

So if I was to go from a blender file of terrain mesh, lets say from the GIS Webgeo setting, is there a way I can send this as a Collada straight to Sketchup. Several times I have tried doing so but Sketchup imports a flat picture of the land I wish to export, rather then a 3D file. I would rather a collada over an stl. I exporting colladas to sketchup may be easy but for some reason the file I exported from blender does not seem to import properly into Sketchup.

If the original surface is not smooth (few edges and faces), regardless of the format used for export (of the many available), it will still not be smooth after import (except for the flat surface, of course). But you can use a modifier in Blender to make it denser and smoother.

Thank you for your efforts, but would you also happen to know how to get around my problem with the collada file. Should the collada files be importing into sketchup from blender as full 3D models, as it is only importing as a flat satellite image in sketchup. What kind of problem is this and how can I fix this?