QUESTION: I cannot Cut my First Object

solid

#1

It’s the first time I use Sketchup, and of course I stumble upon the feared beginner’s problems! :smile:
I created a ring-shaped table but need to cut into two opposite sides a rectangular opening. I just don’t succeed: Sketchup errors with the message, that the shape is not a solid.

If anyone wants to help me, I can send the file by e-mail. The file includes that ring table and the box that is to be subtracted from the table. If you do it, then please let me know, how exactly you did it, all steps involved. Thank you.


#2

If you’re not getting the cuts you think you should and pieces are missing or whatnot, it may be that you need to scale your model by a factor of 100 or so to perform the intersections. Then scale it back down when done. However, if you’re getting the cuts you think are right and it’s not reporting as a solid, it may be due to the fact that the outer surfaces of the slot cutter become the inner faces of the slot. If they are not reversed, you will have the inside of the slot faces on the outside of the slot surface. If they are all okay as well, then you need to group everything in order for SketchUp to analyze the group as a solid. Here’s a simple example … I assumed the slot ran through the table horizontally. However, any other intersection will have the same issues.

Based on this sequence of steps, can you provide more information on what problems you are having?


#3

Sounds like trying to use solid tools without first making solids.


#4

Hallo Hirnsausen.
You can upload the file here and you will get a lot of help and different ways to reach your goal.


#5

Thanks for all the answers, great spirit here in this forum! My appreciation.

Yes, I would like to upload my file so you all could have a look on it and understand, what I do wrong. I need to learn.

But I don’t see the upload button here. I am uploading that file on my website, and give you here the link.

http://www.BigTingsAGwaan.com/d/RingTable.skb
http://www.BigTingsAGwaan.com/d/RingTable.skp

There is that round ring table, and I want a cut into it in the shape of that box (1m wide, from top to ground, and across).


#6

You won’t be able to make a solid from your table until you fix the issues with the top edge (at minimum - there could be more). See attached: you appear to have drawn two circles at different rotations so that their points do not align and they can’t merge.


#7


#8

Upload: thanks, now I know where to find it. Couldn’t interpret it before. Ahhhh, these beginners, right? :smile:

Table: thanks, will have to redo. I saw these diagonal lines, but didn’t knew that the 2D-to-3D making tool would also rotate them.


#9

It is sooo frustrating - I still seem to be totally unable to create valid solids! Thus, making unions errors.

I don’t even know, what I’m doing wrong! I created a circle, took away a smaller circle from its center, and made it 3D. The same procedure 2 times. And still, none of them is valid as a solid. Why???

Please have a look to the file, and tell me what is wrong. Or, if possible, please help me to create what I need: RingTable.skp (157.6 KB)

RING TABLE

° inner diameter of the vertical wall: 5.00m
° outer diameter of the vertical wall: 5.07m
° height of the vertical wall: 0.82m

° inner diameter of the horizontal table plate: 5.00m
° outer diameter of the horizontal table plate: 5.50m
° height of the horizontal table plate: 0.03m
° distance ground to bottom of the horizontal table plate: 0.72m

< This should result that the vertical wall exceeds the top of the ring table by 0.07m (7cm) >

There will be an opening on the two opposite sides that is 1.00m wide, but I will try to do this by myself if we can get the basic ring table being done.

Thanks for your patience and assistance.


#10

I opened your model and triple-clicked the lower cylinder to select the geometry and then made it a group (or you could make it a component if you prefer). The Entity info now says it’s a solid. I did the same to the floating ring and it, too, reports as a solid. I think the part you’re missing is that SketchUp needs the geometry to be grouped or it doesn’t know which pieces to use to determine if it’s a “solid” or not. Creating the 3D shapes is not making a solid, merely making 3D shapes (although most 3D printers will still process items as solids even if they are not grouped prior to export). Similarly, if you group everything, it will not be a solid since there’s clearly nothing connecting the two parts (not to mention that there’s a little guy in the middle who is flat and not a solid).


#11

Found these options (only by right-click on objects). Thanks!


#12

You’ll also find them in the Edit menu,
they can be set to use shortcuts keys, G being the default for Component
and there is a Make Component button on several toolbars.


#13

It seems I have now one more problem:

I exported the file into a DWG file, and imported it into Chief Architect X7. I can see there the outlines, but it is not a solid object - no camera can see the ring table.Did I do something wrong within Sketchup?

Or did I do something wrong the way I imported into CAX7?

Here is the file, please check. Thanks.
RingTableCut.skp (318.0 KB)


#14

I had no problem exporting your file to DWG. Are you sure that you used the Export>3D Model method instead of the 2D Image? Or are you looking at it in a wireframe view? In AutoCad it looks quite OK in hidden-line view.

Anssi
RingTableCut.dwg (221.5 KB)


#15

Hi, and thanks for your time and assistance.

When I exported into the DWG format, it worked, too, no error. And still, when importing it into Chief Architect X7, it only becomes lines, no real 3D body anymore. I am trying to import your DWG file, let’s see.

Meanwhile, I also posted inside the CX7 forum the same question. Another user tried my export file, and said: “The table in your plan file is only a 2D cad block, so it will not show
up in a 3D view. Here is your plan with the symbol imported into your
living room.”

I still have the problem, more assistance needed. If anyone would also have Chief Architect X7, it would be easier to generate the same problems and finding the solution, I think.

Okay, I tried to import your DWG, still the same problem. Points towards the Import features of CAX7.


#16

Okay. It seems, it is a CX7-related problem - their import settings. I am closing this thread here now. Thanks to everyone for the really nice support. :slight_smile: