Problem with sketchup2x-plane extension with sketchup make on windows 7


#1

Hi !
I’ve just setup my sketchup 8 to sketchup make 2015 and when I run it, I have a message says :

`Erreur de chargement du fichier C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane/loader.rb
Error: #<NameError: uninitialized constant Marginal::SU2XPlane::XPlaneImporter>
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane/loader.rb:10:in `<module:SU2XPlane>'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane/loader.rb:5:in `<module:Marginal>'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane/loader.rb:4:in `<top (required)>'
C:/Program Files (x86)/sketchup/Tools/extensions.rb:197:in `require'
C:/Program Files (x86)/sketchup/Tools/extensions.rb:197:in `load'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane.rb:67:in `register_extension'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane.rb:67:in `<module:SU2XPlane>'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane.rb:20:in `<module:Marginal>'
C:/Users/Géraldine/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/SU2XPlane.rb:19:in `<top (required)>'

And the extension is not working as well !!
That such a shame because I need this extension to work on my projects.

What’s crazy is that I’ve tried the same on mac before and everything was working !!
Do you have an idea of why it doesn’t work ?

Thank you.

`


#2

are you using the version that’s installed from SketchUp2XPlane_170.rbz ?
from this link


#3

Yes I 'am ! And I’ve intalled it with the instructions : window/preferences/extensions/installextension…


#4

Might be an error loading the Ruby file due to your username not having ASCII characters - that é might be triggering a Ruby bug. Ruby 2.0 should support unicode, but we’ve seen some scenarios where it fails under Windows. (OSX seems to be fine.)
There are workarounds, but they need to be implemented by the extension developer.


#5

Ok thanks for information ! I gonna tell the developper about that !


#6

Ok it works !!! I’ve change the name of the user directory without the “é” and it’s working !
Thanks for help !


#7

The SketchUp2XPlane code is on Github. There would be a good place to file an issue


#8

Tom,

What is the workaround that need to be implemented? We have also the same problem with Skalp.

regards,

Guy


#9

I’m going by memory here - I use this boiler plate snippet in the ROOT rb file to create some constants with the paths to the extension that I use later:

  # Resource paths
  file = __FILE__.dup
  file.force_encoding("UTF-8") if file.respond_to?(:force_encoding)
  SUPPORT_FOLDER_NAME = File.basename(file, ".*").freeze
  PATH_ROOT           = File.dirname(file).freeze
  PATH                = File.join(PATH_ROOT, SUPPORT_FOLDER_NAME).freeze

Though I cannot recall if there was an additional issue with Ruby C extensions…