Printing in SketchUp for Web

Hi everybody,

We are happy to announce a new capability for printing in SketchUp for Web and SketchUp for Schools that you can try out today.

Similar to PNG export, our Print Preview utility lets you compose your 3D models in the context of the paper space you’d like to print them on. Go to File > Print to check it out.

You can select a standard paper size, or specify a custom one. Just like PNG Export, you can use basic navigation controls (Orbit, Pan, and Zoom) to position your model on the preview canvas. You can also choose to print with a white background, which we hope will save you a little bit of toner.

Of note, we’ve made model scenes accessible in Print Preview (and PNG export), so you can easily jump to scenes you’ve composed in your model. And if you tweak your scene a little bit, SketchUp for Web will save a default “(Last Print)” scene when you print to PDF. If you want to save this scene, just rename it in the Views panel. Otherwise, SketchUp will overwrite the scene on your next export.

You’ll also notice that we are introducing a Print to Scale mode for paid subscribers and SketchUp for Schools users. With Print to Scale, you can compose 1-page scaled drawings at any scale you specify and you can choose to display the scale at the bottom right of your print. In this print mode, the camera switches to orthographic for scaled prints.

We expect to have a help center article up before long with more info about printing. We hope you’ll give it a try and let us know what you think!

Mark

4 Likes

Ever since I went to SketchUp on the I have been looking for the ability to print from the Screen. Now I really need to print. Please direct me to the proper actions needed.
Thanks Al

Which version of SketchUp are you using? Your profile indicates SketchUp Pro but you’ve posted in SketchUp for Web.

If you are using the SketchUp for Web, follow Mark’s instructions above. Click on File and then Print.

It’s actually essentially the same in SketchUp Pro, too.

I’m using SketchUp on the Web. Instructions were perfect. Thank You.

1 Like

Glad that helped.

Please update your profile to help prevent confusion in the future.

I’m I doing this wrong? but SketchUp for Web does not print all the the scenes in a PDF file?
It seems to only PDF prints one scene at a time instead of all available and/or selected scenes in one file.

So I have to manually print every scene as a PDF single file, then open Acrobat, then combine all files in a binder so that I have all the scenes in one PDF file?

That’s the way it works. Nothing you are doing incorrectly. The desktop versions do the same thing.

Which web version are you using? Your profile says you are using SketchUp 2017 Make.

Hello,
great, and if as free users we don’t have access to vector printing, the quality is still good by using big enough paper output.
But how do we set up printing parameters in sketchup web?
In some models, sketchup web will print sizing, others not and I don’t know why.
The preview is ok but the pdf generated will not always include sizing and will always include part of the model (I don’t want) that are outside of the component I try to print.

Can you share a .skp file that is typical of what you are doing so we can see what you’ve got and what you are trying to print?

hello, thanks for your answer,
here:

result not ok table top box.pdf (35.5 KB)
I also tried by exporting to png, same result. Firefox built in print function result in a blank page.
The only way I found, atm is the print sreen key, but on this holidays, I’m on a old little screen, so the result is not always good enough.

How do I share my sketchup web models? I can’t import them directlyto 3D warehouse? I have to download them in skp and them upload them here or in the warehouse?

You can upload them directly to the 3D Warehouse but probably easiest is to download the file directly to your computer. With the main modeling window displayed, click on the button in the far upper left corner that looks like three horizontal lines. Click Download and proceed from there. You can drag the file from your computer into a reply here or, if it’s too large, upload it to Drop Box or Google Drive and share the link.

skp ok: it print the sizing, only one compound so it don’t display anything I don’t want on the pdf.
planche table top.skp (1.8 MB)
planche table top dessus A0.pdf (677.6 KB)
The only issue I have is that now, guide lines (maybe not the right word) are straight line while they was dotted line in previous versions.

skp not ok: sizing are not printed, unwanted components are printed, but they are not much annoying in most cases. This model include the previous model as component.
table top box.skp (2.0 MB)

skp not ok: this model include the previous model (WIP) . The complexity of the model prevent to print components, the preview is still ok but the result is like this one:
Arrière table top.pdf (25.9 KB)
https://3dwarehouse.sketchup.com/model/2f373126-95dd-4616-91e9-6323a9e84c7e/An-arcade-cabinet

So this is the “table top box” file set up for scaled printing. I’m using Shop but it should be similar for you.


The first thing I did is delete the mess of guidelines. Then I selected the back view and Zoom Extents to make sure of the view.

After clicking Print you can set the paper size at the upper right. It defaulted to A4 and I left it. Under Print Mode, select Print to Scale. No need to pick the view because that’s already set. I selected a scaleso the whole thing would show on the sheet. Remember that “In drawing” refers to the print. As you can see I also selected to add the scale to the drawing in the lower right and make the background white. You could turn off the axes if you want in the Display panel.

And after clicking Print to PDF, this is what I get.

In your model of the entire arcade game you’ve got a scene set up to show the back view but the cabinet is in the way of seeing the back of the console. That accounts for the gray region occluding the view.

I notice you are using tags incorrectly in the Borne Arcade file. You have made what you called LAYER1 active. The pencil icon should always be set to Untagged. ALL edges and faces should be untagged and only components, groups, and dimensions should get tags. If you use tags correctly, you can hide all the other stuff and leave only the console visible.

Here I’ve created new tags for the cabinet, the computer stuff and the banner at the top so I can show only the console and its dimensions.

I set up the view to show the back of the console. Parallel Projection, back view, zoom extents. Then I updated your scene. Notice the thumbnail looks as you’d expect.
Screenshot - 12_27_2020 , 10_16_23 AM

Print Preview from this model.

And the PDF export.

That should get you into the shop to build your project. Looks like a fun hobby project. Pretty involved.

Thanks for your time.
Well like this mess of guidelines, it helps for the dimensions and printing the plan on the console top. Whatever I can hide them when I want.
Unfortunately, print at scale is not available for free users. I used it while on trial period on sketchup 2020, but that’s quite short when you don’t have a lot of time et do not do it right.
So, currently, I’m using “Hide rest of model” into “component edit” in order to display and print only the component I want, and unfortunately it works only for display and preview, not the final printing. So instead you suggest me to use layers.
Currently I’m using layers mainly for dimensions in order to hide them when not needed (needed mainly for printing the plan). Sometimes I draw in the wrong layer. Fortunately it’s easy to modify.
So I’m going to apply your tips, it sound good.

You should not be drawing on any “layer” actually called a Tags now, other than Untagged. The pencil should always be on Untagged. Once you have modeled something and made it a group or component you can assign a tag to that group or component. Only groups and components (which should be %99 of your model) should be assigned a tag. All raw geometry should be untagged. Using tags to control visibility is absolutely the correct way to go, but you should start off using them right to avoid problems in your model.

1 Like

Maybe you need to upgrade to SketchUp Shop.

Ok, so you’re right it’s an issue with –layers– TAGS that I had, and I must not use the way I was as I did not understood that components and groups had the tags. So it means I have to use them very carefully, when I’m editing into a component, the tags are like hidden and inherited.
So now it woks at all points: I can hide the stuff I want and print my dimensions!
Thanks you a lot!

Well, it’s not important, the part where I required it is done.
And also honestly, I find sketchup while very easy to start, hard to finish: some bugs destroy the experience (the issue where you needed to draw at like x1000 scale in order to avoid errors if there is sub-millimeter stuff, one of the most annoying seems to have been solved?). And now my issue was that I did not understood some stuff but also that the print preview does not works well.
And there sometimes the issue where models seems lost in approximation: you know you take care to connect everything correctly, to do nice square angles, but suddenly parallel faces become unparallel, 30 cm line became near 30cm, you don’t know why.

I do not pay, so I do not complain, but as a light user it prevent me to pay.

It sounds like learning to use SketchUp properly will go a long way to helping you out. Maybe you should spend some time with learn.sketchup.com

As a hobbyist using the free version I guess you can do what you can do.