Polygons sides problems (with French Keyboard)

Hey there, when I try to create the 8 sides polygon in the fundamentals tutorial #5 I face an issue. I start drawing a polygon, then I try to enter 8s to have 8 sides, but as soon as I touch the s, it opens up the Scale tool… How do you do ? I’m on a mac, that may cause the problem ?

Have you tried typing 8s before you start drawing the polygon? Get the Polygon tool, type 8s and hit Enter. Then click to set the center and drag out.

It doesn’t work. Still opens Scale tool. But I found out that if I type 8S instead of 8s (I keep a finger on the Shift key), it works. I had the same problem when entering a length like 95cm, when touching the m would activate the move tool. This workaround seems to work though. Thanks for your help !!

If you select the polygon tool, while “sides” is still displayed next to the VCB, you don’t have to type the “s”. Just type “8” and press return.
Which version of macOS are you on? I don’t see the same problem here.

That works great! Thanks! I’m on macOS Mojave 10.14.6 on an iMac 2019. But I’m using Sketchup make 2017. I already saw a few differences with what is shown in the course, probably because I use this unmaintained version…

Here’s the screen recording showing the issue with ‘8s’

I tried 8s in Safari, Chrome, Firefox, Edge, and SketchUp 2018, 2017, and 2016. In all cases it changed the number of sides in the polygon I had drawn. Not sure why it was different for you.

Thanks for trying Colin ! I add another video showing the issue for your information.
I guess typing the number of sides without the s before the first click is the solution.

Other useful informations : I use the SU Make 2017 French version with

Pro 30 days Trial License. I use the Apple Magic Keyboard with default config.

@hugo.lehoux thanks for marking my post as a Solution, but I wouldn’t say that solved your isssue, it was just a workaround. There’s something wrong and it hasn’t been solved yet.

You’re right, I would probably be punished on Stackoverflow for that :wink: Turned it off then until it’s solved :slight_smile:

The French keyboard is part of the reason it’s happening. The release of the shift key is acting like an inference lock update. The other factor is that it only goes wrong in Safari. Try Chrome.

Thanks to all of you! The problem is coming from the keyboard then.

Just for information, I’m using the unmaintained Desktop version of Sketchup Make 2017 so the error is not only limited to Safari I suppose.

  • Using the web version in Chrome works perfectly as expected.
  • Safari is causing problems as @colin just mentionned. Even the workaround using ‘8S’ doesn’t work.

I’m very pleased to discover the great support community around Sketchup by the way :wink:

To be fair, the problem isn’t the keyboard, it’s the way that Safari handles the release of the shift key while you are currently entering text, and the way that SketchUp doesn’t cope with that. I logged a bug about the issue a few weeks ago, because it’s also not possible to enter other combinations, not just the s for segments.