Performance issues with MacBook Pro

performance

#1

Hi all,

I’m experiencing some rather frustrating performance issues with SketchUp 16 on my MacBook Pro.

It’s very slow to copy, paste, move stuff around and save the file. Some of the files are quite big - one for example is in and around 250mb. The files contents are office layouts with maybe 50 or so desks, chairs, monitor arms etc. along with a few meeting rooms with chairs, sofas etc. (basically a floor of an office block with everything you can imagine it containing, from chairs to computers).

My MBP is the best one currently on the market and has the following spec:
OS X EI Capitan
2.8 GHz Intel Core i7
16 GB 1600 MHz DDR3
AMD Radeon R9 M370X 2048 MB

Should this computer be able to handle this no problem? Is file size an issue? I.e. should I be aiming to keep files below a certain size to keep it running quickly?

Much appreciated for any advice given.

Cheers,
Brian


#2

Turn off textures when modeling.

Try to use low-poly components. (Don’t blindly insert high poly components from the 3D Warehouse.)

Put components on layers, and use a combination of scenes and layers to hide things that you are not working with.


#3

Generally, file size is a poor indicator of model performance.
Modeling technique has a tremendous impact upon model performance.



No amount of gee whiz hardware can overcome poor modeling technique.
See this compendium of performance modeling techniques.
How do I make SketchUp run faster? — SketchUp Sage Site


#4

File size is a bad gauge of model complexity because things such as large images and textures can bloat the size without really adding complexity (they are just bitmaps). The real drivers of performance are the number of edges, faces, and distinct materials in the model, which you can see by looking at statistics in the Model Info window. When your edge counts get up to millions, your model will choke just about any computer!


#5

Ok, it seems it’s a case of me not creating models with best practice techniques in mind.

See attached the statistics on the model I mentioned above.

Am I right in thinking this is the explanation?


#6


#7

Probably yes. Most of your model seems to consist of components. If you have inserted a lot of 3D entourage elements (like trees, cars or people) from the 3D Warehouse, you could try replacing them with simpler ones. It is not feasible to build a forest of 3d tree components. the trick is t use 3D things at only critical situations where they are to be viewed from very near, and use 2D cutout images for things further away.

Anssi


#8

Thanks Anssi, I think that must be it.

I download a lot of DWG items from manufacturers sites and insert them. For example, detailed ergonomic chairs with lots of curves etc. I would then multiply this component by the number of workstations in the model. In the above case there is 40+ so this must be causing it.

I’m thinking a better approach might be to put all seating on a layer and have it turned off and only turn it back on when I’m going to render.

What do you think?


#9

Related question to Brianbe’s:

I haven’t really 2013 MacBook Pro 15 inch retina, 2.7 GHz Intel Core i7, NVIDIA GeForce GT 650M 1024 MB w/ 8MB ram, OS X 10.9.5. I have very similar slow issues with sketch up Pro 2017 and lay out. My models are typically in the range of 70 MB, in my layout models 150MB. I create elaborate architectural models with very few complex components. Will I notice a difference in performance by purchasing a new MacBook Pro, or possibly upgrading my graphics processor? I cannot upgrade my 8MB ram on this particular computer, but I’m not running other programs anyway. Hopefully somebody has some experience with this. I cannot determine if my graphics processor maybe slowing me down. Thanks for your input.