PDF files automatically launch print dialog when opened in Foxit?

New user here. I made some drawings, saved some views as .pdfs and sent to a friend. He noted that whenever he opened the files a print dialog was automatically launched. This seems to be specific to the Foxit PDF Reader. I tested this and found the same issue. I couldn’t find any Foxit setting to stop this.

I then viewed the saved .pdf file with Notepad++ and noticed near the bottom these lines:
"21 0 obj
/S /Named
/Type /Action
/N /Print


I removed the word “Print” , saved the file, and reopened it with Foxit. The print dialog no longer launches automatically.

Is there a reason the “Print” action is encoded into the saved .pdf?
Is there a setting that might allow me to turn off that “feature”? I don’t see one.


1 Like

Perhaps the command is Print to PDF because most users would want to print the thing?

What sort of problem does it create?

It’s not a huge deal, just a minor annoyance to have to close the print dialog every time you open a file when you only want to view it. If I’m sharing a file I’d like to save the viewer the annoyance. :slight_smile:

I prefer .pdf for viewing rather than .png or .jpg, because of scaling.

I could be wrong, but I could not find any way to directly export pdf from the web version of SketchUp, only the print to PDF option on the print dialog. And indeed, a pdf generated that way has an embedded print command and pops up a print dialog when opened by the PDF viewers I have tried this on. This does strike me as a bug, though a silly one because SketchUp does generate a PDF file on your computer - just one with the print command embedded.

I noted this issue last year in another post related to a PDF printing bug (yet to be resolved)…but it didn’t get any traction, perhaps because I didn’t break it out as a separate post (note you have to open the post and read down to the next paragraph to see what I said about this Print problem):

As noted by @slbaumgartner, the Print dialog (sometimes) forces you to save the PDF file before it brings it up in the viewer along with the Print dialog. So, yes, IMHO, this is a bug, not a feature. Note that I said it ‘sometimes’ forces you to save the PDF file before printing…but not always. Have you noticed this too? I haven’t been able to pinpoint exactly when it does this, I just know that it doesn’t always force you to save the PDF file before it brings it up in the viewer.

I’m not sure I follow. When I select “Print” my only option is to print to a PDF file (aka save the PDF file.)

Sometimes when I press the Print to PDF button, it doesn’t bring up the Save As dialog…it just opens it in my Adobe Reader…with the Print dialog open, of course. If I want to save the PDF, I then have to do a Save As to save the PDF. I’m on a Windows 10 laptop, don’t know if that has anything to do with it.

For fun, I just closed all my SketchUp windows & browser tabs & killed all the Chrome processes. When I restarted SketchUp and tried to Print, it brought up the Save As dialog. However, subsequent Print’s DO NOT…it simply opens the PDF file in my Adobe Reader. I found that it is actually saving the PDF file to my Downloads folder, with a name of model-name.pdf…always with the Print dialog open :roll_eyes: