Paint Bucket & The Materials Panel

I’m wondering if there’s a fix/setting for this that I’m unable to find: I work with the side panels hidden in order to maximize my screen real estate/modeling workspace and I access all tools strictly by keyboard shortcut. When I hit the shortcut key for the pain bucket tool, it always automatically unhides the side panels in order to bring up the Materials panel. No other tool I can think of does this and since I’m often just using whatever material was selected last, I don’t need this feature and I’m wondering if there’s a way to disable it so I can keep working without the constant disruption of the side panels popping up and having to re-hide them.

go to the SU preferences, at the bottom of “drawing”, you can diable the automatic invocation of this panel.

Here is the french panel, it should be the same in whatever language you use :slight_smile:

in french

EDIT : apparently the english version is “Auto-activate Paint Tool”. literal translation for once :wink:

I don’t have this setting in SketchUp Pro 2022:


Could someone at SketchUp/Trimble please help with/explain this?

@ateliernab shows the Mac UI and your profile says you are using Windows. They are different in this regard. The Materials panel should be showing in the Default Tray. There is no way to defeat that. You could create a new tray that only has the Materials panel.

1 Like

owww, yes, I completely forgot it’s mac only, because we use macOS colour tray. A month without teaching it on PC, and I already loose my head.

my bad. Didn’t even check on the PC, just there at hand’s reach.

Well, that’s an unfortunate and rather arbitrary nuisance. Thanks for clearing that up. Also thanks, ateliernab, for contributing!

One might get the rest of the OS-specifics for materials, as well.
It kind of reminds me of an old joke:

Beware what you wish for:)