Optimizing Sketchup Memory and Performance

performance

#1

Not really a technical bug, but my model is starting to hog resources on my iMac as it grows, and I am just getting started. It’s OK when I zoom in, but the structure - which is 150,000 Sq. Feet - is getting crawly in full view. Is there a way to optimize memory, clear the cache or some other trick that doesn’t involve simplifying the structure to speed things up?
Particulars of my iMac:
iMac (24-inch, Early 2008), 2.8 GHz Intel Core 2 Duo, 4 GB 800 MHz DDR2 SDRAM, Macintosh HD, ATI Radeon HD 2600 Pro 256 MB


#2

Your machine is 9 years old,
has minimal (1 half the recommended) system RAM,
and 1 quarter the recommended (1 half the minimum) GRAM.

If you can, either double the system memory, or bring it up to 16GB if possible.


Other than that:

Reports that SmoothMouse does not play nice with SketchUp.

Purge the model from the Model Info > Statistics panel

Switch off textures while modeling (shaded should be okay.)


Search the forum on “performance”.


#3

I have a 2007 iMac with an even slower graphics card and you have to model very carefully to avoid SU slow downs…

changing the HD to a 480 GB Solid State SATA Drive made a huge difference [and was relatively cheep], but badly made models still slow it to a crawl…

use a simple Template, delete guides regularly, work on components in a separate file, don’t paint anything with textures until your wanting to export…

I also use MenuMeters to watch my CPU and when it goes high I wait for SU to ‘catch up’ before continuing…

do not load any render plugins when modelling…

john


#4

In addition/expansion to what @DanRathbun and @john_drivenupthewall wrote:

Unless you run short on memory you can apply textures, but switch to the hidden line or shaded (without textures) face style while drawing. Textures increase the file size, but have little effect on performance unless they are being viewed based on the face style.

Also do not turn on shadows until you are finished. Shadow rendering imposes a large burden that can severely affect orbit, pan, and zoom on a complex model.

Close the outliner before doing a complex built-in operation (e.g. a Solid Tool or Intersect with) or running an extension that creates or modifies geometry. The outliner is fine while doing manual editing because a human is glacially slow compared to even an older computer, but the outliner really gets in the way of high-speed automated operations.


#5

I can’t upgrade my computer at this time, but I purged the stats as you suggested. I still have the following:
Edges 387242
Faces 176801
Component Instances 26263
Guides 0
Guide Points 1
Groups 90

Is that a lot? Seems like it to me, but I have a complicated latticework for the outside elevators and I have just begun working on the larger structure.


#6

Did you check the “Show nested components” box on the Model Info>Statistics dialog? The actual face/edge count that SketchUp needs to process would be even larger if the numbers you posted didn’t include components. In my books your model is already huge, but my models are mostly quick detail studies where the face count runs often in hundreds rather than hundreds of thousands.

Anssi


#7

Yes, it’s showing nested components too.
I think it is the two latticeworks with so many beams and cog tracks on its 180 segment arcs. I probably won’t have any single components as complex as those two in the future, but cumulatively, the number of faces and edges might double overall before I’m done (I haven’t even done much coloring yet). The model seems to be performing reasonably well right now, and I can close other programs if it slows down too much too. But is there anything else I can do?


#8

You could take a few Xanax and the whole thing will seem much faster (just kidding!)


#9

Arg. It is really getting intolerable. The model is unavoidably large, and I have only begun to add features and structures to it: Here are the current stats:
Edges 707200
Faces 331666
Component Instances 49573
Guides 0
Guide Points 0
Groups 156
What can I do, other than eliminating design elements, to reduce the load on my tired old iMac? It keeps giving me the spinning wheel and freezing up. Apple must be tired of receiving reports from me by now.


#10

turn off ‘autosave’ and get into the habit of using cmd S instead…
turn off ‘save backup’…
never model with ‘shadows’ on…
disable Trimble Connect, Dynamic Components, Advanced Camera Tools…

re-watch videos on working with large models, you’ll know better what they mean now…

john


#11

That is quite a large number for arc segments. This leads to more edges and faces.


#12

I suggested early on in your development of this model that you should use full detail for only a few segments of your large arc structure.

Think carefully about what level of detail you need for viewing and presenting the full model, and eliminate anything that won’t be visible when zoomed out. If I remember even approximately correctly, your arch is about 600ft radius. (Not at my computer so I can’t look at your model at the moment).

Even on a 5K Mac screen, that means 1ft is only spanning a few pixels.

Put the detail either in a separate sub model, or only on some parts of the full model, and limit zoomed-in viewing of the detail to those part(s) of the model, for example by having separate scenes for them, and/or using layers to turn off detail that can’t be seen or resolved in those scenes.

Otherwise, as you are finding, the edge and face count becomes very large and SU slows to an unusable crawl.

Also consider how you will present or print parts or all of the model, to whom, and why, and select the level of detail appropriate to those uses and users.


#13

Yes, this supports what I am finding, and I have started the detail level set of sketches already anyway. I will have to return to the main arch at some point, once I do some floors (there will be nearly 100 floors) on an individual level and that could prove problematic again. But I’m also finding that if I stay at the zoomed out level, I can move around the larger model without problems. Ironically it’s when I zoom in that SU has to start rendering a lot of faces and edges and it can slow to a crawl, though even then, not always. It’s mainly when I make a change that can effect the whole model at the micro level. As you suggest, I may have to limit those to only the areas that will be seen in the final presentation.