Memory Management

Is there a way ( know I’ve seen the panel somewhere ) that I can increase the memory allocation for sketchUp Pro 2020? I’m running this on a new iMac Pro and it should not be running so slow.

I think that hasn’t been needed since Mac OS 7, certain not since OS X. There are some Unix command to do with getting the OS to favor certain apps, but I can’t remember how those worked.

Having an SSD, more RAM, and not so many other applications open, should help.

The main causes for delays and slowness are style settings and edge count.

I agree with @colin that nothing special needs to be done on macOS to allow an application to use lots of available physical memory.

You can run the Activity Monitor tool (in the ApplicationsUtilities sub-folder) to see how much memory is being used by what processes on the system. Note that there are more than one memory statistic available in Activity Monitor (virtual memory vs. actual resident physical memory, for example). You can customize which statistics are listed in the display.

What sort of SketchUp operations are executing slowly, how long actual elapsed time is “slowly”, and on what sort of model? For example, how many edges and faces does the model, or group, or component, have?

Did the same operations on a similar model run faster in the past? If so, what might have changed between then and now?

Edited to add that having the Outliner window open can reduce performance of some operations, though I think this is less true of SketchUp Pro 2020 compared to earlier versions.

To add to that, Profiles in particular are very demanding.

1 Like

Large model of barn project.
What profiles, Styles and edge counts should I use to speed things up when I am modeling?

Model is 113.4mb

Turn off Profiles under View/Edge Style. You will be shocked how much smoother things become.

The image you shared has shadows turned on as well. I assume that was just for visualization, but on the off chance that you are attempting to model with shadows turned on that would slow things enormously.

I frequently have models that look much like yours but they are rarely more than half the file size. That suggests to me that you might have some high poly count components, or some such, bloating your model.

I have just upgraded to a new iMac from my old late 2012 one. That one was only just beginning to struggle with things so I would expect your machine, which looks even more powerful than my new one, would actually fly, with or without profiles on or shadows on. However, you are limited to the processor speed as SU cannot make use of multi-threading (so you effectively only have access to one core for SU, not the full 10 at your disposal). That’s what I have learned anyway.

@hamatt, make use of:

  • groups + assigned tags (layers) and scenes
  • component’s + assigned tags and scenes

In scenes you should then have certain layer sets visible for modeling, others (currently not needed) are off.

Thanks for all the informative comments. I can’t believe Mac doesn’t support multi-threading. What’s with that?

Best to all.

SketchUp doesn’t make use of multi threading. Apple macOS of course supports it.

Mac supports multi threading. CAD operations are not able to be split into multiple threads, SketchUp along with all other CAD software can only use one core to process with, on Mac or PC.

1 Like

After at least 30 years of trying, nobody - not AutoCAD, not Blender, not anyone - has figured out a way to split an interactive geometry modeling engine into multiple threads in a way that has any important effect on performance. There are too many aspects that depend sequentially on others. This has nothing to do with Mac vs Windows or with memory management.

1 Like

Sry, meant SU. That is informative. Thx.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.