Opening non-SketchUp STL files

stl
import

#1

Is it possible to open non-SketchUp Pro 2015 files? I need to open some files that were sent to me that were not created in SketchUp


#2

you need to use File >> Import …


#3

You need to be clearer.
STL isn’t a natural sketchup file.

What files are you trying to open?


#4

Tried that. It tells me it “Does not appear to be a SketchUp Model” and won’t open it. Tried changing the extension too, still a no-go


#5

To be more specific isn’t really an option as, for example, one file is named Tripod picot top_v.stl


#6

Do you have an stl importer?

Add the stl here and one of us can look at it.


#7

Except you erred in the first post. You said “non-SketchUp 2015 files” when you meant “non-SketchUp STL files.”

Install the Community STL Importer extension from the ExtensionWarehouse.
Inside SketchUp, go the the Window menu. And choose Extension Warehouse, navigate the the “SketchUp Team” store page, and scroll down till you see the STL Import plugin. Choose it, and on it’s plugin page, click the red Install button.


#8

I just tried a file from this page:

http://www.eng.nus.edu.sg/LCEL/RP/u21/wwwroot/stl_library.htm

I could select the file and choose options, but as of yet SketchUp hasn’t finished trying to import the file.

I force quit SketchUp and tried a simpler file. That worked, though the model has some messed up reverse faces.


#9

I’ve got the STL importer and have successfully sent a print job to a 3D printer. I’ll give the “Uninstall/Reinstall” a shot.


#10

Nope…didn’t work. Uninstalled, then reinstalled the STL importer.


#11

The next step is posting one of these “problem” STL files (or post a link to it.)


#12

At 143 MB it’s larger than my company email allows to send.

However, here’s a smaller file that I could open. Maybe you could look at it and figure out what I could do with the monster file.
Tri Pod Scanner1.stl (2.32 MB)


#13

Then share it with Dropbox or some similar service.

If the “problem” STL has faces that are too small SketchUp may be having trouble during the import.


#14

Importing this file, here’s what I got. As you can see, even setting the scale to meters, there is a lot of very small geometry that is going to make this very difficult to work with in SketchUp. However, the shape itself really isn’t all that complicated and wouldn’t be too difficult to redraw natively in SketchUp. I suppose that doesn’t help with your monster file…


#15

Yes and no. It explains why my computer stand at “importing geometry” for hours and hours…and hours until I get frustrated and assume its not importing and shut the program down. Maybe if I leave the computer on overnight, by next wednesday it will open…

Thank you for your help!


#16

One option for the huge STL files is to import them into MeshLab, and export Collada. SketchUp at least shows a progress gauge when importing the Colada file, instating of locking up with the STL file.

Having said that, the progress bar hasn’t moved in a while…


#17

I’d like to get a hold of that monster .stl file. I have a command-line stl to skp converter I’d like to test.


#18

I’d love to send it but it’s too large for my companies email system and dropbox is blocked for usage on my end.


#19

I think I can send a link to my dropbox - all you’d need to do is upload it. Let me see,…

I guess it isn’t easily possible as I thought.


#20

Here’s is a smaller STL file (under 13MB) that still is enough to lock up SketchUp. When converted to DAE it becomes a lot bigger too, and takes a long time to import into SketchUp.

http://colin.scienceninja.com/man.stl