Number shows but dimension line doesn’t show on floor plan

When I add dimensions inside the room on this plan, the number shows but the line and arrows don’t. Why could that be?
The dimension lines PaunHouseTemp3.skp (2.5 MB) of the rooms show fine.

Lovely house!

But there is something very odd going on in this model.

I can’t see any dimensions that are just showing a number, but missing the line and arrows - can you illustrate one with a screenshot?

But when I open the model, and view the Plan scenes, ALL dimensions in ALL of the Plan views show a question mark (?) instead of a value.

It is easy to fix each individual question mark value - just edit the dimension value and replace the ? by angle brackets <> which SU will replace with the measured dimension when you press {Enter}.

But why they are happening in the first place, I don’t know.

I have no difficulty in adding a new dimension inside a room. If I orbit the view slightly, I can see that the dimension end points are at the top of the wall, so the lines and dimension values are well ‘above’ the room floor, and all details are visible.

Are you by any chance placing your dimensions ‘on’ or below the floor? If so, the lines and arrows might be ‘below’ the floor and hence not visible, but the dimension value might have a small positive ‘Z’ value to prevent Z-fighting in the view.

I can’t think what else would be causing your problem - which as I said, I can neither see in your existing model, nor reproduce.

Is there any particular reason why some scenes use arrowheads for the dimension lines, and some use slashes?

I’m seeing the same on my mac…

@huckrorick, what font are you using for dimensions?


Sorry, I didn’t explain the situation fully. This is a house in another city from me that I am working on remodeling. The configuration of the plan is accurate but the dimensions are approximate. I put “?” in each of the dimensions so that someone in the other city will measure and send me the accurate dimension for each “?”.
I am adding the dimensions inside the room when looking at a plan view (top view, parallel projection) with a section plane active. I believe I am getting the dimensions into the same plane as the floor. But why aren’t they showing? When I tilt the angle of view the dimensions are visible. (See 2 views below). Red arrows point to the example dimensions.

I think I’m see everything that’s in the model, so you may have a graphics card issue if you see less than this…

there are some minor issues with dimension layers, but I can see them…

You should fill in your profile with your system specs…


I can see your 4’6 dimension in full in both PlanFlr1 and PlanFlr2 scenes, but not the 5’ one at all - even when orbiting, and even if I turn on Xray view. And turning On the DimensionsSection layer makes no difference either.

Also using a Mac, for what its worth.

PS. The 4’6 dimension is on Layer0 - should be on one of the FlrDimensions layers, I guess. But turning on or off Flr1Dimensions or Flr2Dimensions layers makes no difference either - still can’t see any trace of your 5’ dimension.

But If I go to the PlanFlr2 scene, and add a dimension for that wall, I have no trouble in getting a dimension of 5’ to show in full.

Sorry, I’m negligent. I made some changes to the file. Here is the version with the 5’ dimension.
Question I would have is: Looking in PlanFlr2 (and PlanFlr2) scenes can you put a dimension that is visible inside the room, snapping on the corners?
My system is an XPS15 Dell laptop. intel core i7, 16 GB RAM, 64 bit operating system, Window 10 professional, 512 GB SSD, NVidia GeForce GT 750M display adapter. 4K display.
I am definitely not seeing what John is seeing.
PaunHouseTemp3.skp (2.6 MB)

there are known issues with high res displays, this may be one off them…

I can see the 5’ dim lines fine from all angles and can add more easily…


Thanks for the quick reply. I am going away so I won’t be able to check this until tomorrow.
Thanks again.

You’ll probably not see this till tomorrow,

Just tried your latest model on Windows 10 laptop, SU 2016 Make, with modest resolution (1366 x 768) - NOT high res.

Your dimension is on the floor, and only the 5’ value is visible initially. The lines and arrowheads become visible if you turn on Xray view, or as you found, if you orbit the view.

The lines and ‘arrows’ (slashes in this case) must be being seen by SU as ‘below’ the floor, though not by a visible amount. A ‘quirk’ of the SU renderer, perhaps?

If I recreate the dimension by picking endpoints at the top of the wall,or on midpoints of the verticals, it displays fine.

See if that works for you too - AFAIK it should.

I was hoping to avoid that solution because 1) it’s easier to select end points when I’m just looking at the plan view and 2) I prefer having the dimensions at the floor level. But I guess that is what I have to do.

Perhaps submit it as either a feature request, or (maybe?) a bug?

It is certainly very odd that even a tiny amount of orbiting reveals the lines and arrows in full.

does the same happen if applied in ‘perspective mode’, I find PP is only reliable for exporting and never use it when modelling…


It does not happen in perspective mode. Weird. However, for a plan view I need parallel projection. Perspective obscures some information. However, I found a very funny work around. I can rotate the parallel projection just a very tiny bit, not enough so you can really see it. then the dimension show.

I would say this qualifies as a bug.

I did some testing. This does not occur in other situations. There is something about this model that is causing it. But what?