Never ending deviation (axes and degrees)

Dear SketchUp community!

I have made a rather similar related post not too long ago, describing a persisting issue which throws me off when modelling.

I’ve been working on this project for a few months now, and for an unknown reason I’ve kept getting a small amount of deviation.
Tried to rectify the problem by starting a completely new project and importing components from previous projects (not just by copying them, but by choosing them from the Components tab - so that the components would arrive in “neutral form” without any deviation imposed by previous project).

I can’t seem to fully solve it.
Whenever I am trying to use common tools (such as the Push Pull tool), when measuring distances and angles it keeps showing me the “~” symbol and it really makes no sense :man_shrugging:

I do have splayed walls and other components at various degrees, but there is no perceivable error occurring whilst modelling and placing them…

I would love to hear your insights on the matter.

In case anyone wonders I am using a supported browser (Chrome).

Appreciate it!

1.Gilos Studio Design.skp (3.4 MB)

First thing to note: Turn off Length Snapping. It causes just the kind of small inaccuracies you describe. (Window menu>Model Info>Units)


First order of business is to open model info>length units> and turn off length snapping, then resave the project. This is known to introduce small errors is models and is best left off at all times.

Secondly, looking at your file can you give an example where you are seeing the tilde, some specific measurement? That might help us see what you are seeing and find a reason. You have display precision set reasonably high (.000 cm) but not to it’s highest setting (.00000 cm). But for this type of model that is probably overkill.

I see some objects with dimensions that don’t seem to be as nice as they might be. From what I can see, though, that is due to having Length Snapping enabled in most cases. As was mentioned, this should be turned off for precise modeling. In some cases the odd dimensions appear to be related to the angles at which you’ve cut some of them and in others, they look like cumulative discrepancies, again because of having Length Snapping enabled.

I see nothing that indicates a bug, though.

Curious: Is this a sort of home studio you are building for yourself? What is the raised frame sort of thing on the floor?

I’ll upload here an example of one place where I have found the issue:

It seems to sit correctly on top of the “Floor” yet, I can’t explain it but it isn’t “straight” or perpendicular to the floor (I am referring to the rear “plasterboard” wall).

btw I noticed that if I disable angle snapping it won’t remember that for the next time I am opening the project (after saving of course), while length snapping would remain disabled.

This is a project studio I am working on for a client, it is indeed more of a “home” studio, but criteria-hitting dimensions (even if a tad small space).
I apologize, what raised frame? what is the name of the component?

Thank you all!

Ah … You should not be using SketchUp Free, then. You need to be using at least SketchUp Go if not Pro.

They aren’t components. They are unnamed groups.

Angle snapping does not have the same error causing problems associated with it and does not need to be turned off. I’m not sure why that setting does not persist through a save on the SketchUp Free version you are using (perhaps inappropriately), but it does not need to be turned off.

Ah … You should not be using SketchUp Free, then. You need to be using at least SketchUp Go if not Pro.

HAHA as soon as the client said we are Go ( :wink: ) with the project I have upgraded to the Go, paid version, plus it works very well when I need to show it on the tablet when at the location…

They aren’t components. They are unnamed groups.

Oh these are the plasterboards prior to raising them up to their full height, I would have to model the channels and the studs afterwards.

1 Like

Very bizarre, I won’t be disabling it if unnecessary.

I am using the Go version but yes, web version nonetheless.

1 Like

Please update your forum profile.

That makes sense.

Apologies, I have done so now.


So I decided to dig a little deeper…
Could someone explain this to me??

What have I done so incorrectly?
i think that from now on I will be using the finest decimal value.


As has been mentioned several times in this thread, this sort of tiny inaccuracy comes from having length snapping enabled. The snap to a specific length fights with the inference system, so edges get forces very slightly out of alignment to make the edge length correct, which is what it is being asked to do. Many of us have been asking for many years for this to be turned off by default but for some reason the powers that be think it helps people by making a pseudo grid system. It only works for coarse snapping.
Unfortunately once the error has been introduced it propagates through the model and is difficult to eliminate. Turning off length snapping doesn’t ‘correct’ the errors in an existing model, but turning it off in your template means you shouldn’t have the problem in your next model.

GIF 14-02-2024 2-44-37 PM

Well, it appears that all I needed was this explanation…
It makes perfect sense!

Thank you!!!