Nested Instances when trying to combine 2 solids


I have been using SketchUp for a few months now but just started trying to model for 3d printing. I have been using Solid Inspector 2 which has been extremely useful. I have run into one problem though. I have created 2 different solids. I need to combine the two however. When I move one solid to the other, trying to make them flush I end up having a problem with “Nested Instances.” When I try the “Fix All” button I get a pop up stating “Some errors could not be automatically fixed. Manually inspect and correct the errors, then run the tool again.”

If I move the two solids apart and run it again I have no problem. I have searched for hours for a solution but I am left scratching my head.

I hope this all made sense. I’ll attach a screen shot along with the file itself. If anyone has any tips or advice, I would greatly appreciate it.

Thank you,
carnastions2solid.skp (146.7 KB)

Nested instances is simply telling you that you have two separate solids. If you use outershell on them they will become one single solid.
GIF 5-01-2024 4-13-12 PM

Thank you for your response. I followed along but got different results somehow. I tried a screen recording but for some reason it doesn’t show my menu selections so I took screen shots of all the steps showing my results. In the end, it deleted one whole Solid Group. I’ll attach them here. Hopefully it makes sense.

I’m sorry to be difficult but I really appreciate your help!

I’m sorry I can’t replicate your results, I’ve tried it in three versions of sketchup and it just works.

Perhaps undo and try again, or download the version you attached and try with that one, something may have changed.

I have tried everything I can possibly think of. I’ve even started from scratch and am still experiencing the same problem with a different design. I get lost in trying to find a solution online. Are there any resources you can recommend for not only understanding the Nested Interface problem but 3d modeling in general? I really need to understand. Without fixing this problem, I will not be able to 3D print anything I design.

The only way I can get the “nested instances” message to show up is if I start Solid Inspector2 with nothing selected.If that’s what you’re doing, it’s just a case of not using the tool correctly.

This might be dumb, but I thought for it to print properly, everything has to be one single solid. (I did this using “Outer Shell.”) When I select both pieces individually and run Solid Inspector 2, I don’t get any errors (just like your video). Can the 2 solids be separate, like your video, as long as they are adjoining and print properly.

Actually it doesn’t have to be a single solid. All of the objects need to be solid. If they are contacting each other the slicer should treat them as a single object. That has nothing to do with your complaint of Solid Inspector 2 showing nested instances, though. Solid Inspector 2 is only going to tell you if the selected object (group or component) meets the requirements for being solid.

I resized your model so it would fit on the bed of my printer. It’s still the two solid objects as you shared the SketchUp file. Here is a screen shot in the slicer. No errors.

And the preview after slicing.

That’s because you’re using Solid Inspector 2 the way it is designed to be used. Failing to select an object before getting the tool is the incorrect way to use the tool.

I see a potential problem if you want to unite both solids.

Click in sequence on the scenes tabs of this SU file.

carnastions2solid - JL.skp (402.6 KB)