Model Info Window Disappeared

SU 2022 Pro, v 22.0.354, Win 11 Pro

I opened SU Pro tonight and the Model Info Dialog has disappeared. The title bar is there, but the dialog window below the title bar is missing.

What I’ve done so far:

  • I disabled all of my plugins and restarted SU. Same Issue.
  • I ran the SU installer and selected the repair option. Same Issue.
  • I logged in and out of SU - Same Issue.
  • I opened SU 2021 and SU 2020 and Model Info dialog appears just fine.
  • Restarted PC. Same issue.
  • I wrote an AutoHotKey script to resize the window and the dialog portion of the window came back. However, when I close and reopen Model Info, it’s back to just the title bar and nothing else.

THIS IS NOT an issue where the dialog is off screen. I can see and move the title bar around, but nothing else is visible.

There have been no Win 11 updates recently, and the only SU plugin update came today from FlexTools and it was working just fine after that update.

The only thing I haven’t done is reinstall SU - dread setting up all of my plugins and toolbars again…

Any thoughts/help are appreciated.

Unistalling SketchUp then reinstalling it, won’t disturb your plugins or your preferences. Those are kept. It should completely refresh the Program Files folder, but then a Repair should have fixed any corrupted window resources.

I would try an uninstall, reinstall next.

Does going into Preferences, Workspace, Reset Workspace help?

No, I tried resetting the workspace, but it had no effect on the Model Info window.

Looks like I’ll have to bite the bullet and reinstall.

Thank you for the response.

Before you reinstall: Open Model Info, then press alt and spacebar together, then tap m followed by any arrow key, then without clicking move the mouse around until the dialog appears on screen, click to finish.

@DaveR - Thanks for your response.

I did all of that yesterday. As noted in my first post, the issue is not the window hidden off screen somewhere. I can actually see the Model Info title bar, move it around to any of the 3 screens I use - I just don’t see the rest of the window - only the title bar. Alt-Space+arrow keys lets me move the title bar all over the place, but still no dialog.

That being said, I completely uninstalled SU, reinstalled it and still have the same issue - it leads me to suspect there may be a plugin issue. That seems odd since the plugins I use are tried and tested and have not, so far as I can tell, caused these types of issues with others.

I can work around the problem by running the autohotkey script to force a resize of the window, after which I can see the dialog. But closing and opening Model Info takes me back to just the title bar. Very weird.

Sorry to get involved.

This is what I’m getting when I open Model Info Window:
image

After AHK script that simply resizes the window using the AHK command
WinMove,Model Info,0,0,500,400
image

Not at all, appreciate any help I can get.

I haven’t done much by way of Ruby scripting - is there a quick and dirty ruby solution to resize the window? It feels like the dialog height is being reset to zero somewhere?

Also wondering if the appdata\webcache folder has anything to do with it. Can I uninstall - wipe that folder and reinstall without issues?

I don’t know that there’s any way to change the size with Ruby but them I’m no Ruby guru.

You might try this:Go into User/AppData/Local/SketchUp/SketchUp 2022/SketchUp/Private Preferences.json. Open it in Notepad. Scroll down and look for what I show in the screen shot. Edit the numbers to something like mine. Save the changes and restart SketchUp.
Screenshot - 6_1_2022 , 7_08_42 AM
Does that help?

1 Like

@DaveR Funny, I was looking at that as you were writing. I don’t have a PrivatePreferences.json, but SharedPreferences.json. I modified shared adding the section you provided and copied to private.

I inserted the section under the heading “Shared for All Computers”

Still have the issue.

That’s because you were looking in the wrong folder. Look in the one I listed. Local not Roaming.

No. Not for resize.

However you can open (but can not close) the Model Info dialog by typing it to Ruby Console e.g.:

UI.show_model_info("Credits") 

Where the "Credits" can be substituted with the available model info pages such as "Animation", "Classifications", "Components", "Credits", "Dimensions", "File", "Geo-location", "Rendering", "Statistics", "Text", "Units".

You can also try the following two commands if have any influence or not in your case:

UI.refresh_inspectors
UI.refresh_toolbars

@DaveR - Sorry, it’s 5:30 am and I haven’t had my coffee yet…

I opened the right file this time and noticed the section also had the line:
“minimized”, true
I changed it to false.

That worked!

Thank you, DaveR!

I have ticked the Solution box.

2 Likes

Thank you @dezmo. The solution was provided by @DaveR - the problem was in the PrivatePreferences.json file.

1 Like

I suppose mine doesn’t have that line because the dialog window wasn’t open at the time.

Glad you got it sorted.