Model, contours from drone survey: importing basics

I can’t get any recognizable results by importing any of the ELEVEN download options provided by a website ( that hosts drone-survey data for commercial clients in support of their customers. Listed downloads are as follow:
3D model (51.6 MB)
DEM (WGS84) 18.59 MB
Contours (WGS84) 525.31 KB
Ortho TIF (WGS84) 279.77 MB
LAZ (WGS84) 89.71 MB
LAZ (UTM) 89.71 MB
Ortho JPG (WGS84) 21.25 MB
Ortho JPG (Small - WGS84) 4.65 MB
DXF (Large 500k - WGS84) 16.83 MB
DXF (Medium WGS84) 8.70 MB
DXF (Small - WGS84) 3.59 MB)

At minimum, I’d hoped to import contours as 3D, then do some editing in SU to clean them up and limit their footprint to my property, but I can’t even get THAT far.

In my dreams, I’d import the full model, find that it’s got contours and other imagery info in separate layers, but at this point, I’m miles from that, it seems.

I’ve tried three times to import the 3D model (51.6 MB), and after 15 minutes or more of autoCAD-entity processing (“merging entities…”), I get what might be a series of line-segments splattered along the blue axis - useless.

Importing the DEM file is suspect from the get-go because it downloads to my PC as an image file (JPG). It opens as a 2D shaded rendering of my contours - as if I’ve imported a flat scan, etc.

I’ve also repeatedly tried to import Contours. It extracts from download oddly, as if it’s an image file that my photo-viewer would open, but with a dxf extension. If anything results from that import, it’s again all stuck to the blue axis and utterly useless.

The “DXF (Large…)” file gets to 99% in the Sketchup import process, then either hangs or moves so slowly that I’d have to rely on my kids to take over where I left off.

LAZ (UTM) doesn’t seem to appear as an import-friendly file type in SU.

The Propeller website support is pretty good, but they seem to be unfamiliar with Sketchup, so it’s up to me to try to bridge the gap. There was vague second-hand info that came from them thru my drone guy, questioning whether SU would require me to use a WGS84 vs UTM setting, but to my knowledge I have no control over that - true?

Thanks - Dave

Did you mean redirects to

Do you have to sign up to look at their models? If not, can you show a direct link to the models you’re downloading?

Thanks Colin - You’re right, I think I got the site’s name wrong; I actually log in through what I guess would be my drone guy’s client portal, . As such I think it would be difficult to get you directly logged in, but I just looked at the website and I can share downloads with you. Wanna PM me your email address?


Your link let me log in with my Google account. I found the site you were testing with. The Small DXF file works ok, though they do have all of their faces reversed.

The Contours file also imports ok, but it is all just contour lines, not sure if it would be easy to use.

I could bring in the 5k jpeg, and project it onto the small dxf import, though they were the same size, and it didn’t really line up.

Using the SimLab OBJ import extension I could select the model. I used the trial version, don’t know how much it costs to buy. It didn’t yet finish importing.

Will report back when the model imports or fails.

The model did eventually import. It’s huge though, and the SKP version is 1.45 GB.

Colin - REALLY? Why not for me, then?

I’m using a trial version while at work (still ‘pro,’ though) so I don’t get it. I get the same absence of results whether at home or at work. (Home version is pro, but I think it’s 2015-ish.) Any special settings you used during import?

By model - did you mean the first (51.6MB) one? Does it have a bunch of layers, more or less photorealistic? (At 1.5GB in SU, I’m thinking I’d crash…were you able to orbit or make any changes?)

Contours: imports as 3D? Or flat, like a flatbed-scanned image?

Thanks a bunch for the verification that it at least works (for someone…)


SketchUp doesn’t normally import OBJ, but with the extension I mentioned I could import it. The 264 MB OBJ becomes 1.45 GB SKP. Doing anything to the model is painfully slow. It does have a photograph texture.

The Contours comes in as 3D, the lines are as much up from the ground as they should be.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.